Firmware updates bricks my VeraPlus

These are new out of the box vera’s, how can the clean up space before the update?

SSH is always enabled. So, setup, no fw update, clean space, then fw update.

I’m sorry to hear this. As far as I know the guys are still working on this matter. I’ve asked for an update for you guys.

LE: we currently have a developer’s only v7.32 closed beta build that will address these issues with VeraPlus and many more.

We also have a solution for this which should also be ready by the time 7.32 will be public.


Sorin, when will 7.32 be public? My 2nd new, out-of-the-box Vera Plus is useless at this point.


These new units bricking to sounds like the openWrt version is not right for the 7.31 update. Quite a few reported bricking installed Plusses and Edges with the update and it had to do with the openWrt version.

Look at the file /etc/openwrt_build and make sure it says 240 for a Plus (133 for Edge) before trying to update. If it is an order version, first contact Vera support to have this corrected.

Cheers Rene

Can support fo anything for a new just unboxed one that is in the corrupted state or just return it (again)?

Don’t know. @Sorin?

Advice for now seems not to upgrade a new unit with version 7.30/7.31. I hope Vera/Ezlo will pull this version for now.

Cheers Rene

1 Like

I’m not sure whats the technical explanation behind it but as a temporary solution would be to let our customer care do it either if it’s a new or existing controller. Our product management told me that the solution for this is a two-phase one. A new firmware (7.32) and a cloud counterpart update which is about managing the upgrade process differently. They assured me that once 7.32 is live these issues will be sorted out for good for the VeraPlus’es.

How do you not upgrade a new unit? As soon as I try to connect it goes to updating controller (step 3 in the setup process) and then I’m stuck.

Factory reset the unit, do not activate. Then ssh into the unit, free disk space as in my previous link. You should be able to update after disk has space.

How do you factory reset the unit that seems to be stuck updating? I tried the 3 clicks within 6 seconds, 6 clicks. Held for 10, 20, 30 seconds. If I hold reset while cycling power than all the lights light up but the power light just keeps blinking. Doesn’t respond to ping or ssh at any of these steps. Is there some other process I am missing?

try this => Video: Recover Bricked Vera plus - Community Playground / General Discussions - Vera Community (

1 Like

What if the unit is extrooted? Isn’t that the best solution to avoid getting bricked?

It’s not supported after 7.31, if I remember correctly.

I have my Vera Secure on 7.31 (ver 1.7.4971, March 2nd, 2020) - and it’s extrooted. I have ignored the latest update since it doesn’t bring anything useful to the table (for me).

7.31 is the current FW. if you’re already on 7.31, the disk partition has already been changed and you should not experience the problems reported in this thread.

Same here - packing it up to send for refund - unless I get an easy answer. You cant sell brick"ing"/“ed” devices.
At least in the APP maybe you say something?

Tried customer care - no response.

I had a good call with customer support last night. Tried to get it to respond to a TFTP server to enable SSH but unfortunately that didn’t work. I am returning the unit for a refund. It seems like certain batches have the auto-update issue and they said if you decide to get a new one. Do NOT go through setup without calling support first. They can enter the MAC address on their end blocking the auto-update. Then they can SSH in and make enough room for the update to complete.

I had two Plus’s brick on initialization. I got a third one to work by asking Vera to remove the serial number off the server auto firmware update list. Tech support got it started and manually installed several sequential firmware updates in a support session. It took about an hour for then to get it done. Works great!!! Vera support is awesome…

1 Like