Fibaro Universal Input sensor FGBS321

I’ve been using this Fibaro input sensor with four DS18B20 probes for six months to measure water temperatures. It was working perfectly up until the last couple of days when I noticed that I was getting the occasional spurious (maybe one per day) temperature reading (e.g. Over +1000 degrees!) from different sensors at different times (usually late at night). Last night one of the sensors stopped providing a reading. I’ve power cycled the Fibaro a couple of times and I’ve checked the sensor using a stand alone temp meter and it seems to be still working so it looks like the Fibaro may have decided to ‘exclude’ that DS18B20.

Just wondering if any other users of the Fibaro Universal Input sensor have seen similiar behaviour?


… and … yes here as well.

I did some further investigating after I posted and noticed that the child device of the non-reporting sensor had no capabilities listed on the settings tab while the others did. I inititated a ‘Configure node right now’ command on the parent device and that restored the capability listing on the child device and it re-commenced reporting. So it looks like Vera was the source of that problem rather than the Fibaro. The last update from the sensor seemed to correspond to the time that Vera was running a nightly heal (around 02.00am) so I guess something must have gotten corrupted during that process. The sensor has thankfully been running ok since then which is a relief as I have a couple of months of Datamine logs which would have been messed up if I had to exclude the Fibaro to replace the sensor.

I’m figuring the spurious readings may be due to electrical noise so I’ve added some filtering to the powerline at the Fibaro and also a small decoupling Cap across the DS19B20 power rail. I didn’t get any spurious reading over the last 24 hours but its too early to tell if this has really solved it. I’ll post an update in a few days.

I have been using the same device with four sensors for about a year, suddenly today they are all showing 0 degrees.
I’m not sure what the problem is.

I had to disconnect one of my 4 sensors (trial and horror) and the rest of them started working again. I have been waiting for replacement sensors a month now (china purchase…).

okay, thaks for the input.
Did any of yours show 0 degrees?
My Vera is at my cabin so there is little I can do now…

If I remember correctly all showed 0 degrees.

Here is an update, I took a trip up to my cabin and disconnected sensors, on by one untill the others started showing temp. So one was defect. But after a couple of hours one of the sensors started showing 128 degrees…the 2 last one is still ok.

Some others who have had the same experience?


Hi, i just wonder if you you did get your sensor? And have you tested it? I’m still waiting for the one i’ve orderd. And i was curious if you did make it work.

same here… it reads 128 degrees sometimes… just unplug the fibaro and plug it back into powersupply and it functions ok. thought it was a loose wire at first so i soldered the thing. had this idea it is a problem with the connector with wires into the fibaro as when i push that a bit while it is connected all of sudden it works normal again.

Do you have stable readings after cap installation? What size did you choose?

My new probes has arrived. Will do some testing now again.

I’ve been getting stable readings since I added the powerline filtering and the decoupling cap. My guess is that probably the decoupling cap has helped most as I have 4xDS18B20’s each with a 3m cable terminating back to a piece of stripboard on which the Fibaro is also mounted. I think it was a 0.1uF decoupling cap I placed on the stripboard across the TP(3.3V) and Gnd lines to the DS18B20’s (I don’t rely on parasitic power for the DS18B20’s).

I can’t be certain that this has resolved the issue permanently as they had been working fine for +4 months before I began to see the spurious readings. That said, I was then getting at least one every day and since the modifcation that has stoppped.

that could be it… some sporadic powerdrops on the parasite powerline. now that u mention that i had plugged in some laptop powersupply’s when that 128 degrees temperature showed up. these things give little sparks on the same 5 port powernode i have the binary sensor connected. the other tempsensor i have never had any abnormalities like this. had this thought that i might be fahrenheit readings but that didnt make sense as it is 25 degrees Celcius stable at the tempsensor. i tested and plugged in 2 laptop powersupply’s of 6,3A in and out a few times on the powernode which sparks a little when connected and indeed the tempsensor got stuck to 128 while doing this.

The DS18B20 is a well used temp sensor for many purposes, and for what i can see it’s mostly been used with a 4, 7k resistor between +5V and data. Could that be something for FGBS321?

That pull up resistor is probably already build into the fibaro device.

Did anyone else have trouble getting the temperature sensors to detect properly and add the right devices in Vera?

When I installed mine I had the parent “Motion detector”, two child “Motion Detectors” and two “GenericIO” devices. I had to change Device type to “urn:schemas-micasaverde-com:device:TemperatureSensor:1” and device_file to “D_TemperatureSensor1.xml” on the advanced tab of the “GenericIO” devices to get them to be recognised as a temperature sensor.

I also had one sensor displaying 128 consistently till I cycled the power to the Fibaro Universal Binary Sensor.

I had heaps of trouble getting it to include and had to follow the reset procedure a few times (to reset, hold the B button down and keep it down for 10 seconds while you apply power and then cycle power again).

I’ll keep an eye on the values and see if I need to add the capacitor to clean up the power.

Thanks to all for posting their experiences and suggestions!

I’m looking forward to playing with the Universal Binary Sensor a bit more, I am thinking I’ll build a little switch plate for major area’s which uses the inputs to set the status of key rooms, ie. Turn on/off auto light management

I have two Universal sensors with 4 temperature sensors on each.
One of two Universal sensors freezes with no temperature changes. The I need to “Configure node right now” to make it respond again. Sometimes several times before it can connect to it. It seems like it can’t connect it because it often say that it isn’t possible. The suddenly it’s able to configure it and everything works again.
It does that almost daily. It’s very annoying and I can’t rely on them.
Has anyone same issues and solved them?

Same issue here, no solution.
Just two sensors connected on shielded 1meter wire and the second one 25 cm further. Worked for two weeks before both sensors stopped. The input I’m using to detect if a relais is on or of kept working fine. After re plugging in the mains just one of the two sensors came back. The second one started working again after a ‘Poll now’.
Hmm, come on Fibaro!