Fibaro dimmer and S2 button as scene controller

Thx for the reply.

The switch is 24V rated so this will not work :frowning:

I need a little more help regarding assigning a scene to button S2. I have set parameter 41 to “1 byte dec” “1”

And then what? Where do i assign the scene no. to the button?

Regards Jens

Has Vera created a Scene Controller device for your dimmer? This would have a device ID three higher than that of the parent dimmer device and is probably named _Scene Controller.

You should be able to select that as a trigger source for a scene in Automation, New scene, TRIGGERS. The scene number that will be triggered is complex - it depends on what type of switch (momentary or on/off) you are using and the settings of config. variables 14, 15 and 19. I suggest you read the data sheet to determine your situation.

Hi again

it true I now have a 2_scene_controler in the triggers. but it does not show up in “all devices” not even under “no room”

I have both the no. 14, 15 and 19. parameter as default so I believe it has to be id 26 as a one click for S2.

Now I just have to get home to confirm it.




I have now been home testing and it doesn’t seem to work.

It looks like the scene controller is not the right one. The one i have is ID 2 and i think its one there is there by default.

The dimmer has ID 26.

I set the proberty 41 to 1 but the new scene controller dont show up under No room, how do i get the new scene controller to apear?



I also tried this, and I was not successfull. No SceneController gets created, I don’t see any when setting the parameter 14 (not 41 if I am right!) to 1. Would you mind quickly describing step by step how ou achieved this?

To be honest, I have no idea how/why I got SceneControllers for some (not all) my Fibaro modules. MCV has also not been able to figure it out. I’m not actually using them and have hidden them.

I trigger scenes by just using the status of the S2 switch as with any other switch.

It is parameter 41 for setting the scene functionality on an FGD211. Parameter 14 sets the type of switch being used.

OK, I don’t have any parameter 41, it fails if I try to set or monitor it.

I guess that is because my dimmers are to old (Version 1.4), in the manual for version 1.4-1.8 there is no parameter 41:

Which version do you have?

Can you explain this “I trigger scenes by just using the status of the S2 switch as with any other switch.”?

The latest version of FGD211 is 2.2 but I think parameter 41 appeared at v1.9.

Vera usually includes an additional device for each Fibaro switch or dimmer. It usually has a device ID two higher than the main device and reflects the state of the S2 input. Recent Fibaro versions (>2.0?) give instant-update for this. Older versions had to wait for the next poll. You can use the state of this device to trigger a scene or PLEG input.

parameter 41 indeed appeared on version v1.9 and higher. you can see the version number your device has on the advanced tab of the device. look at versioninfo , the last number is the current firmware on it.
i have been puzzeling to get it to a higher version but it doesnt seem to work. it requires a (zip) firmware file send using the z-wave ‘COMMAND_CLASS_FIRMWARE_UPDATE_MD’ and only works from v2.x versions and up of the devices firmware.
if you happen to have a v1.9 or higher firmware you can use the scene-controller parameter 41 to 1 to activate it and this will create a scenecontroller on vera for the device which you can set to be able to use 3 scenes for s1 and 3 for s2. it wont work using s1 as switch and s2 as scenecontroller. to be able to use s2 on older firmware versions of fibaro device you would set parameter 7 to 0 and make a group ID 2 under device options and add the device you want to turn on/off in that group. this device chosen can then be setup as trigger for a scene in case you want this.
edit: tried on my fibaro binary sensor… doesnt seem to create a scenecontroller anymore on latest vera firmware 622 :-s seems vera is missing this functionality all of a sudden. up till now i also didnt see a 2nd device created for the s2 input. probably me… also this strange move of taking the e1 from the duo-switch i dont get. dont get mcv sometimes. why not remove the e1 from rgbw controller and the main device for the binary switch. perhaps someone can explain me what i missed ?
edit2: after some reading elswhere it seems the s2 functionality breaks the normal usage for s1 contact. till v2.1 it seems not to work correctly. therefor i advice not to use it to avoid trouble.

Has anyone figured this out?

I can confirm that paramter 41 is only available in dimmers which have version 1.9, as for the moment I don’t have any newer ones. But so far no scene controller has been created on my vera.

What I basically would like to achieve is to disconnect the switch from the light itself, meaning that I could freely use the switch to do whatever I wish by using logic on the vera.

I too would like to use s2 as a scene controller. The version in settings says “3,3,42,1,7” Does this mean I have version 1.7 firmware?

Yes this does mean you have a version 1.7.

However, so far this scene controlling stuff is not working yet. I have a ticket open at MCV and we are trying to figure this out. I will let you know if there is any progress…

[quote=“chixxi, post:14, topic:176314”]Yes this does mean you have a version 1.7.

However, so far this scene controlling stuff is not working yet. I have a ticket open at MCV and we are trying to figure this out. I will let you know if there is any progress…[/quote]

Thanks for the info chixxi, that is disappointing. I would very much appreciate it if you could keep me updated. :slight_smile:

i had this too but somehow this scenecontroller dissapeared over time and i have no clue what happend with it. have you tried setting the parameter on the device and after it set exclude the device and include it again ? if i recall it was something screwing up the scenecontroller so they removed the feature in latest firmware for vera also breaking scenefunctions of other remotes. hopefully they come up with a solution as these universal sensors from fibaro could be great and cheap for using as a scene-controller.

This looks really really interessting:,17409.0.html

Gonna try right when I am home.

It is now working! See the link above.

I got hold of a dimmer with v2.2 firmware. On this one I set parameter 41 to 1, but no new scene controller device appeared. Did v2.2 firmware remove this functionality?

It is exciting that people are having some success. I am confused about the solution in the link though. Is the solution to get a switch to activate a scene via s2 or does it activate a scene by double clicking on s1? And what is the significance of scenes 24 and 26?

Update: I’ve just set up a PLEG as per the instructions and s2 on the dimmer is now able to active different scenes either via single or double press. Thank heaps! :slight_smile:

@DragonVera which device property are you using in PLEG? sl_SceneActivated?


Name Device Name Device Variable Last Change Value
SceneActivated Upstairs Hallway Lights sl_SceneActivated 2013-11-09 18:07:26.689 0
LastSceneID Upstairs Hallway Lights LastSceneID 2013-11-09 18:07:26.731 26
LastSceneTime Upstairs Hallway Lights LastSceneTime 2013-11-09 18:07:26.774 1383980846

Strangely though, I’ve just tried to do exactly the same setup with another fibaro dimmer (with same firmware Version 3,3,52,2,2 ), and on this dimmer I can’t seem to find the device variables sl_SceneActivated, LastSceneID or LastSceneTime when I look for them in the PLEG. ???