Fibaro 2x1,5kW switch toggles on/off

[quote=“hek, post:20, topic:173264”]Also tried to turn of Vera when I had problems yesterday. The toggeling stopped.
How and why the Vera affects our units is still a mystery to me.[/quote]
That was actually no the result I was hoping for, since I have sent my plug-in device for RMA. If you have a configuration that have this issue, could you please open a support request with micasaverde… :-[

After a long discussion with Vesternet (who has opened a support request to micasaverde) I will send in two of my Fibaro 3kw for RMA. It is still not fully clear if it is Vera or the units that is faulty.

But some switches seems to be more prone to toggle. Maybe HW version or firmware is involved… nobody knows yet.

Same problem over here. Multiple fibaro switches tried, but always switch closest to vera starts to toggle. Any solution yet?


I have the same problem with a 2x1.5kw one. I didn’t know i wasn’t the only one.
I replace it with a wall switch Busch Jaeger
The switch is situated very close to the unit. The BJ switch does not have this problem.
The strange thing is, it occurred when both switches were activated. Turning one switch off solved the problem (there was no load yet on that one). The load on the active one is 3times a 3x2watt LED spot GU10.
Also the toggling often happened in a 30sec-60sec-30sec sequence, i measured it once.

I have a 1x3kw one 20watt load and dimmer 70 watt load in my chickenshed which is around 20mtr away and didn’t see that one toggle yet.

I have a open ticket with Micasaverde and they are investigating the problem - one of the last responses I got from them is;

I see that device was reconfigured at the time you experienced this behavior again and then indeed there were some commands sent by Vera but I didn't enough information to know exactly if they have been issued by Vera itself or from the UI. From what I have right now it only seems that all those commands have been sent manually from the UI. I'll keep analyzing the logs but please let me know when it happens again and hopefully I will get more information.

I’ll keep posting here if I get any more information.

Got a new plug-in module back from RMA. Let’s see if I can re-create this again…

I was realy interesting to find this thread…

No to my input to this problem.

I to live in Sweden.

The things that is problematic for me is the Fibaro FGS221 Switch Insert 2 x 1.5kW
now to sometihing interesting.

I have NOT a micasaverde Vera…
I have a Fibaro HomeCenter 2 and have the exact same problem as you people have described (quick on/off switching devices that dont respond to inputs), as it is the switches (the 2 closest to the controller are the problematic ones), so to me it must be either a z-wave network problem independent of the controller or the fibaro devices.

Hmm… but it was some of you that hade devices from other manufaturers as well.

I think I found the problem (or my problem at least) ;D

It was the Fibaro modules that was the problem, I ordered two more modules and they works like a charm, the new modules I got are made 30/10 2012 - and the modules I had (they are sent back to Vesternet for replacement) were made 18/9 2012.

So maybe if all that have problem with Fibaro modules can post the manufacturing date (it’s printed on the box the module came in) we can find out if there is modules manufactured within a specific range of dates?

My problematic 3kW relays is dated 30/8/12.


I also have the issue with Vera Lite and two different Fibaro 2*1.5kw switches.

The first switch I RMA’d some 10 days ago and replaced with my second switch. It turns out that the second switch also have the same problem but it doesn’t “flip” as badly as the previous one. As some previous poster reported, it only seem to occur when both outputs are driven and when the Vera Lite is powered on.

If i power off the Vera Lite - it works ok.

I also had a everspring plugin module in the same room which has always worked flawless, but the fibaro missbehaves regardless if remove all other z-wave devices off or not (as long as the Vera is enabled).

The manufacturingdate of the unit I have now is 18/09/12, let’s home my replacement units will work better.

very interesting I experienced exactly the same.
I didn’t have this problem with older versions of the Fibaro but all the new 2x1.5KW switches seem to quickly switch off/on when VERA sends certain commands like configuration.
For example when you select ‘configure now’ in the interface you hear the switches clicking off/on 3 times quickly.
I got a suggestion from Tane webshop ( to set Poll this node at most every … seconds to ‘0’ (=poll never) and this seems indeed to help. After playing around excluding the fibaro, re-adding, ‘configure now’ and set poll never the switches are now completely quiet/stable!

This issue seems to relate to the fibaro’s showing version number 3,3,42,1,7 (which you can see in vera on the settings tab)

My older switches show version number 3,3,20,1,4 and did not exhibit this behaviour (I always had them on default poll interval and no click/click issue).

I now discovered a second problem with the newer version: the e1 switch does not update in the GUI when you manually toggle the S1 switch. e2 (second switch) updates in realtime when you flip the switch… searching for more people experiencing this issue now…

The new switches I bought has version 3,3,42,1,9 - I will try to see if the UI updates when I manually switch e2 on them. I have sent my switches that were switchning on/off to Vesternet for replacement so I can’t test them.

I got my switch back from RMA and now everything is working well.

My RMA units is also working fine so far.

I just checked mine, version info 3,3,42,1,7

I’ve got my RMA units yesterday and they are all working fine!

Any updates to the issue from MCV? I’m starting to face the same problem for one of my duewi plugin switch as well. Once I turn off Vera, it doesn’t toggle. Resetting and excluding/including doesn’t help.

When it toggles, the power is cut but it actually remains as “On” state. I will need to turn it off and on via the UI…

Has anyone solved this problem?
I have one fibaro 2 x 1.5 kW unit flickering. It is quite close to the vera but it is not the closest unit. I have two other controlling my irrigation.
The load on the flickering unit is quite low. 4 x 5W LED lights on one switch and then 65W on the other.
I dont really understand this minimum load requirement. I can understand it for the dimmer but this unit is just switching a relay…


I had this issue, but Martyn was very helpful in Vesternet and pointed out that I could set the config params as a test…

I changed 4 under device options to 0

This fixed it… If you more info, please ask…

4 is Relay output 1 and 5 is relay output 2
Therefore add these as monitored device options
If they are not zero then change from monitor to 1 byte dec and set as 0