Error trying to create profile for UI7

I just upgraded my Vera 3 to UI7 and have successfully logged into the device via IE. I tried to access the unit via my Grasshopper app on my Windows 8.1 phone but got an error. I used the Reset All in the Grasshopper app to reconstruct my access profile. When I select MMS UI6, type in my username and password, and hit the lookup and create button, I get the following error “Index was outside the bounds of the array”. When I hit the lookup and create button again, I get “Authentication Failed” message.

Any suggestions?

I suspect there is something unexpected getting returned from their authorization service that the code is not handling properly. Their new auth service are pretty complicated to work with so there is probably a bug in the code. Send me a email ( and lets see about setting up a temp readonly account so i can diagnose. That will be the simplest way to find the problem. If you setup one up, test it again using that temp account to confirm the same behavior happens. Thanks.

Spencer :slight_smile:

Thanks Spencer for the quick response. For everyone interested it looks like it was an issue with my account getting corrupt during the upgrade. I created a new account for the read only on my controller and noticed my original account didn’t appear in the list of users on the controller I also noticed some flaky behavior in the UI7 with my original account. I deleted my original account from the controller and re-added the account back to the controller. After this process, I tried my original account on the Grasshopper app and was able to log in successfully!