Error message "Can't Detect Device"


I use the plugin Netatmo for several weeks. It works great. I try to understand why I have this error message that is found in the attached capture screen.

Thank you! For your help.

I assume you are using the install from the MiOS App Store, rather than the latest from here,30478.msg247304.html#msg247304 ?

I have another question.

Is it possible to read the value of the battery gauge and temperature gauge outside?

If so, how?


Is your original problem solved?

I will make some tests this weekend.


Yes, you should find the relevant variables under the main Netatmo plugin device.

Dear All,
I just purchased the NETATMO weather station and tried to use it through my Vera Edge Controller (UI7, Latest Firmware). I installed the NETATMO Plugin from the Vera Web Page but I get an Failed Authorization Failed message. I went the the device Netatmo in the Advanced Section and insert my Client ID and Secret (after I created an app on the dev page of netatmo), and also the username and pwd to login to my atmo web account. I show a post where I could download the latest release of the plugin, which I have done (its a file), but I have no idea how to install it on the Vera controller. Thank you in advance,


The App Store version is not the latest. You looked here:,30478.msg247304.html#msg247304

Unzip the archive and user the UI page Apps > Develop Apps > Load Files to upload the to Vera.

I’m working (slowly) on a store update. Sorry.

Thanks for your fast response. I uploaded the lua files as instructed but the problem remains the same. “Netatmo : Authorisation failed” Is there any chance that the plugin is not compatible with the 1.7.1598 Firmware?


You are absolutely sure you have your correct username, password, clientId, and clientSecret input correctly?

You DID tick the checkboxes on each to allow test entry (I assume you are using UI7) before doing so?

Yes I’m sure that my input is correct, I tripled checked it. The username and password that I’m inserting is the credentials from the NETATMO webpage right? Not the credentials of Vera.

Yes, that’s right. Do you see all four credentials correctly displayed in the device variables? Do you have clientId and ClientSecret the right way around?

By far the most common cause of an “authorisation error” is an authorisation error!

I finally got managed to make it work. It was the bloody restart Vera that I was missing. Thanks for your superb support and help.


Delighted it’s working for your now !!

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules