Enroll to our Linux Beta Program now

Do what?..

Having Vera Secure or Vera Plus running in Ezlo firmware.

No not yet but its coming apparently at some point.

Only the Vera Edge currently can run the Ezlo Linux firmware.

How can I have Vera Edge running Ezlo?

You can install the new Ezlo Linux beta Firmware on to the old Vera Edge hardware.

I wouldn’t recommend you do this in an already working production environment.

OK if you have a spare Vera Edge unit and you want to play around with the Ezlo firmware.

I never did this as I was sent an Ezlo Atom and Ezlo Plus hub for beta testing.

However I believe this thread here was the correct one for having the Ezlo firmware running on an existing Vera Edge.

I had a spare Vera Edge and upgraded it using the instructions that @cw-kid cited. It has worked flawlessly. Currently, I am only using it for automated ezlo-hub-kit automated regression testing.. Seems to work as well as an Ezlo Plus and IMHO, better than the Ezlo Atom for the more complicated, larger number of devices, installations. If you have a spare Edge, it is a great way to get a feel for Ezlo’s Linux hub products.

1 Like

I upgraded a Vera Edge to Ezlo firmware, It seemed to upgraded successfully as LEDs showed(On and Solid). but I couldn’t connect to unit as it was offline so I decided to downgrade it as I read on How to upgrade to new Linux Firmware on Vera Edge using a flash memory.
Trying to reset Vera edge in order to downgrade it is not successful as LEDs turn on and off one after onother.

It will show as Offline in the https://home.getvera.com gateway as there is currently no Web GUI.

You can only connect to it via the Vera mobile app and presumably also via SSH command line if its like the Ezlo Plus.

even in Vera Mobile app it is offline.
it seems I do not have back up in my flash I connected to vera.how can I downgrade to Vera firmware?


Can anyone from Ezlo assistant this user please, who is having issues with the Vera Edge and reverting back to the original Vera firmware after a failed attempt to install the Ezlo firmware.

Thank you.



I’ve opened a ticket for you, with the reported issue -> ECS-430.

Whenever you bump into an issue, please open a ticket using the steps described here. After you’ll create an account (in case you don’t have one already) you should be able to see the above issue, and select to be notified when there is progress.

Let me know if I can help you with anything else.



Hi @Alireza44907,

If you can get to the hub via the API Tool (https://apitool.ezlo.com/) then you can submit this as a custom command. It will restore the Vera firmware (not just Luup)

    "id": "123456",
    "method": "hub.firmware.luup.switch",
    "params": {}

Cheers Rene


I face the offline issue with my Vera Edge when I upgraded it to Ezlo. Even I tried using Ezlo Atom (2 different units) they were offline too. How can I get information about servers like their IPs and ports to ping them?

HI @Alireza44907,

Note that the new Ezlo FW does not have a web interface and will show as off-line in the home.getvera.com list of controllers (maybe that message can be changed, @Ioana . It can only be accessed via the Android or iPhone apps.

Cheers Rene

For all Ezlo hubs the message in webUI should already be there, saying that the VeraMobile app must be used with download links to App Store or Google Play. I’ll double check to see if there is a bug.
The only untreated case should be for VeraEdge using Ezlo Linux fw, as this is just in Beta now.

I know that but even using vera mobile it shows unit offline. I have not tested the unit with a new account or an account without vera units linked to it. Does it matter?

It should not affect in any way if you use the same account. So, in your case, the unit never appeared online in the VeraMobile app?

Yes, I think the issue is about my Internet provider, that is why I look for IPs and ports

Hi @Alireza44907,

The local communication to the controllers is at port 17000 , but i do not know all the ports that are used to connect to the Ezlo servers. What I can see is https (433) and 8001 as outgoing, but those should not be blocked by you ISP or you would have loads of problems.

To find out the local IP addresses of your controllers you would have to look at your router.

Cheers Rene