Eaton Cooper Battery RF Switch as scene controller?

I purchased an Eaton RF9575DLA hoping I could use it to control an existing Z-wave light switch. Does anyone know if this is possible or can it only control an Eaton master switch? I can get Vera to recognize it but can’t seem to get it to control anything. I’ve tried creating a scene and making it a scene controller, and I’ve tried creating a group to have it control a master



It doesn’t work as a scene controller. Instead you need to setup a direct association to the z-wave light switch you wish it to control. These are fantastic little switches!
In the Vera UI, click on the Device.
Click Device Options
in Group ID type 1 and click Add Group.
Then click the Set button and slsect the switch you want to control.
Save an dapply changes.
Wait for the switch to wake up and be associated (I think you can wake it up by pressing buttons on the switch)

Thanks for the reply. That is exactly what i want it to be able to do, control another switch. From your experience, can it control any switch or only another Eaton / Cooper switch?

It can control any switch or z-wave bulb.

Thanks so much for confirming. Maybe you can help me figure out what I am doing wrong. I add the switch to Vera, and it shows up with no issues. I turn “automatic configuration” to yes. Then I goto settings, create a new group, and select the device that I want it to control. Does that sound right?

You don’t need to do the autoconfiguration step. Not sure what that does, but not needed.
You must use Group 1, “Group” actually means “Capability” in terms of association, so the number you use is important. the cooper Switch only supports Group 1.

You should probably unpair the cooper switch and start over (associations can stay on the device even if Vera doesn’t think they are there, unpairing clears all pervious incorrect associations).

If you use Group 1 and it is still not working, than post the device you are trying to control here. Some Z-wave+ devices don’t like the older non-secure protocol so won’t listen to the commands of the association unless you do some additional settings. (but that is very unusual, it is usually a problem the other way around… trying to get a z-wave+ device to associate and control a non-z-wave+ device)

I’m sorry, I just can’t figure out what I am missing. I’ve paired it and unpaired it several times. Here is a screen shot of the settings. The switch I am trying to control is a GE Z-Wave Plus Smart Lighting Control Light Dimmer Switch 14294

Thanks for helping me!


That looks right (assuming that is the snap shot from the Cooper switch) Have you tried under Advanced tab on the Cooper switch to “configure now”, and make sure it succeeds is setting the association (make sure to press some buttons on the cooper to awake it up after pressing configure now).

I don’t see anything on the GE switch that would prevent it from working, but it is a z-wave plus device so it is possible it doesn’t like the non-z-wave plus signal coming from the Cooper (but as a mentioned it is usually the other way around that is the problem, trying to have a z-wave plus device control a non-z-wave plus device).

Also I assume these switch are within a reasonable distance of each other. Direct Association doesn’t use the mesh, if they are too far apart (too much interference) they won’t work.