DSC Security panel cant find USB Port

Hello All. I have a Vera Plus running firmware 1.7.3501. I had to unplug my vera from the serial to usb adapter so I could move my vera to another part of the house to include a new device. After moving the vera back my security panel device can no longer communicate with my actual panel. Looks like it cant find the USB port. This happens every time I have to include a new device. I have checked all the configuration I can think of to check and everything looks right. The port is setup and is using the correct device, the device is pointing to the port. I’ve tried removing the devices and plugin then reinstalling, I have even tried backing up the configuration doing a factory reset then restoring, but nothing works. In the past the only way I have fixed it is to factory reset and rebuild my entire zwave setup from scratch and doing the dsc setup last. There has to be another way!

Has anybody had a similar problem? Can anybody recommend another possible solution or work around (other than buying/making a 100ft usb cable for the next time I need to add a device)

Leave the USB to serial adapter plugged into your Vera and just unplug the serial cable - should work a treat.

What information are you gleaming from that serial interface and are you using a plugin to interpret that? I have configured two programmable outputs on my DSC that I am in the process of trying to feed into my Vera via a Z-UNO, I didn’t realise talking to it via serial might be a possibility?

I’ve done some hunting and it looks like the IT-100 module might be what you have used for the serial interface, and then I presume a plugin that can translate the data protocol?

I have heard though that while this provides everything from status to zone triggers, once the DSC system is armed none of that data comes through - only alarm trips/etc?

Interesting though.