Does Vera Edge need access to the internet to get the time?

We noticed that Vera was using the internet and when we disabled the extra IP ( on our router, the scheduled schemes stopped working (the times are wrong). Is it necessary to have internet access for time or is this a configuration setting we missed?

All Vera controllers need access to a time server to set and maintain system time. They do not have a hardware real-time clock. It’s possible to set up a local NTP server and edit some Vera configuration files–search the forum for more info. Vera also uses the internet for a number of other functions, e.g. automated backup, log archiving and user alerts.

Thanks … that is what we needed to know. We do not want to use the internet at all if possible. I’ll search the forum.

Start here: Securing and stabilizing the Vera by taking it off the grid

@rafele77 has done heroic work on this…

I deleted my post because although it appeared to work initially that was not the case after a few hours.

Do you know what the default NTP IP address is? on our system it is We are testing setting this as the IP address for the Vera Edge controller to see if that solves the problem,

That’s a private IP address. There’s no such thing as a default NTP IP address

You could try
Which is the IP for


I’m confused here. If you are looking for an NTP server on your LAN, you’ll have to set one up on a computer that’s up 24/7 and can connect to the internet in order to sync with external time servers. You’ll then need to edit the shell script in Vera that points to the NTP servers to point to your new server. As mentioned, there is no such thing as a “default” NTP server.

Obviously I used the wrong term when I said default. I hope this is a better explanation.
We bought Vera Edge because it supported not using the internet for operation. We assigned it IP number and blocked that address from the internet. However, later we found that Vera was using another IP address to get the NTP. That address was My question should have been how did it get that number? I thought it was a default but obviously not. I spent a lot of time attempting to assign the NTP to use our router. It seems that was not necessary since we assigned the Vera controller to use as its IP address.

Hmm ok this is a bit muddy.

Do you mean that Vera is connecting to, which is acting as an NTP server?

Or do you mean that Vera has been assigned as its IP address by your router?

If a) What’s your router IP? It’s conceivable that that’s your router IP and and it’s transparently forwarding NTP requests to an NTP address that it’s aware of. This would be something I’ve never seen though

b) This would be an issue between Vera and your router / DHCP server. Doesn’t help with the NTP server though.


It’s still a bit muddy for me.

We installed Vera Edge and assigned it IP It worked OK. Later we discovered another IP assigned to Vera ( If we linked to it also went to the Vera home page. If we blocked that IP Vera the scenes didn’t function because the time was not being returned. Our research indicated that this IP was necessary for time management and that it was necessary to configure ntpclient to use the router ( After doing this we discovered that ‘181’ was still assigned and if we blocked that IP Vera hung. Eventually we decided to change Vera to use and that fixed the problem of the extra IP.

So for whatever reason your LAN was assigning an IP address to Vera (and it was accepting it) other than the one that you assigned.

It’s possible you had a duplicate.

So if you get the Vera page when you go to 0.181 that’s nothing to do with NTP

Have you blocked 0.181 from reaching the internet?


Didn’t Vera need another IP for the NTP server? That is what I understood from the thread HSD99 gave above.
At present Vera only has one IP … 0.181 and we have blocked it from reaching the internet. And the time is correct. So, probably my changes to the ntpclient config worked.

Thats’ incorrect. Vera will have one IP address that it will use to access a LAN, or the internet if connected to a router. Vera makes its NTP requests to the OpenWRT NTP servers by default, which are on the internet. If you have an NTP server running locally on your LAN, you can modify the Vera scripts (see threads from @rafale77 for details ) to point to your local NTP server.

If we blocked both IP addresses (0.30 and 0.181) the time did not get retrieved. If we only blocked the initial IP address (0.30) the time was correct.
How did Vera get the time if it didn’t have a valid IP address to use?
(As I said earlier in this thread I did update the Vera scripts (ntpclient config) to point to our router which also serves as an NTP server.)

If you’ve blocked its access to the internet, unless there’s an RTC it won’t get the time at some point.

Something in the description is missing or inaccurate, but of this we can be sure. Unless something is relaying NTP signals, it can’t get them. Simples


I was wrong about blocking the IP address not causing problems. After some hours it did cause the UI to hang and I had to unblock it to get it to work. However, it appeared to still execute the scheduled actions.
But the thread mentioned by HSD99 above states that it is possible to use a router as an NTP and that is what I modified the ntpclient configuration to use. Is that wrong? If so it exposes a security weakness.

Using your firewall to block the vera IPs will cause the vera to hang crash and reboot unless you did what I did in my “take it off the grid” thread. It involves modifying a lot of files which disable the vera’s connections to the server and one will still be needed: the event server which records the alarms and alerts of your vera to the server. If the vera cannot reach that server, it will constantly retry and accumulate these events albeit at a lower and lower frequency until it eventually saturates itself and crash. It is a buggy implementation and prevents a fully offline mode. Every other servers: remote access, time, logs, backup, etc… you can either disable or redirect using my script but you will still need the vera to be connected to the internet. I have made the request to fix this event server for several years and have been acknoledged by CS (even got me to test a specific firmware attempting to disable this “feature” but ignored by the devs as the test failed.

If your router supports NTP or you can make it run an NTP server sure you can use it. Out of the box, though, very unlikely