Device Settings: How to set negative Number as value?

Hi there,

I own a zwave eurotronic spirit thermostat and I want to set a temperature offset.
This means: changing zwave parameter 8 to a number between -50 and +50 (-5 c, +5c).
I want to pick a nagative offset (-50), but I am not able to set this (0xCE / FFCE), it always shows “current value 255” instead of -50.

Any ideas what I can do or how to set this?

Tobias

You could try to set Parameter number 8 with 1 byte Hex and value “CE”. Based on the device manual and their example, it should work like this. Also, you could try to set the parameter on “Monitor Only” and see the current value and it’s format while in default.

But I strongly suggest that you get in touch with the manufacturer as they will have the correct values for sure.

Let us know if you managed to get this working, I’m curious too.