DataYours on Docker

Hi Akbooer, et al,

I wanted to let you know I have published a docker image of DataYours. It runs openLuup and is specifically configured for DataYours. I am working on another Docker image of just openLuup that could then run whatever other plugins you’d like, but I had to configure this one to allow for setting of Vera IPs and other specific DataYours configurations. This was inspired by the the RaspberryPI thread.

My main goal was to get DataYours running on my Synology, which I successfully have done through Docker.

You can find the image here: Docker

Specifically, for datayours to work, there are a few settings that have to be configured.

  1. DataWatcher must be running on your Vera and configured to send its data to the proper IP and port. DockerIP:2003
  2. Configure your docker image to expose these ports: 2003/udp, 3480. Port 80 is really optional and can be ignored.
  3. Configure your mount point for the database files. I have it on a folder on the Synology - obviously, you need to decide how this works for you. It needs to map to the internal /nas directory.
  4. Configure your remote Vera IPs. This is done through an ENV variable “veraips”
    ***My assumption is that you can have multiple Vera IPs and just separate them by a comma. If someone could confirm, that would be great. I only have one vera up at the moment.

Here is an example of the run command:

docker run --name DataYours -e “veraips=” -v /your/local/directory:/nas -p 2003/udp:2003/udp -p 80:80 -p 3480:3480 airedale/datayours

For the Synology configuration, I am going to post a quick writeup on my website and share that with everyone shortly.

In terms of running the whole entire DataYours with a Vera Bridge, I am considering going down that path, but need to solve some things that happen with the way the code interprets the host IP. Docker uses NAT, and therefore the IP for the links is incorrect. I will work through it though.

Sorry, I missed this post somehow (seems to happen quite often, but I do use the “marked all messages as read” button quite often too.)

This is impressive. Thanks for sharing your findings. Way outside my range of ability to do!

Thanks :slight_smile:

I have a test version of openLuup now in a docker container as well. It wasn’t a far stretch from getting dataYours to work, but I had to account for a few more things.

I am not really sure if AltUI is working as expected in there, so I actually need to get AltUI setup on a box that isn’t a docker container to see if it is working as expected.

Here is the link to it: Docker

  • I have yet to do a full write up like I did for dataYours

Hi there,

Thanks a lot for creating this docker image. I installed it on my synology and got it up and running in less then 10 minutes. Previously I also tried to install openluup on a raspberry pi but unfortunately I am just not skilled enough with the linux command line. This docker image really worked out of the box! -:slight_smile:

So I have been playing with this for the last half hour and here are some of my observations:

[ul][li]The Synology 5.2 Docker gui has a bug and wouldn’t let me download your image. I solved this by logging in via SSH and run the command ‘docker pull airedale/openluup’. Once the download completed I was able to find the image in the docker gui and start it from there.[/li]
[li]I noted down the redirected ports for port 80 and 3480 and than ran the various checks as described in Akbooers user guide. All working fine[/li]
[li]Finally I was able to run AltUI via the command: http://:3480/data_request?id=lr_ALTUI_Handler&command=home#. Again all working fine -:)[/li][/ul]


[ul][li]I rebooted the docker image just to try this out and when I wanted to login again I got the error message ‘No Handler’ I retried a couple of times and finally got it working again. However I noticed that all changes I made had dissapeared. I guess my question is how can I save any modifications? Do I need to configure something on the Synology/Docker level? Assign a folder to write to or something?[/li]
[li]I do have a vera lite running on the same network and I was wondering how I should configure openluup to use it’s devices via the Vera Bridge? From the user guide I read the following:
“If you have installed the VeraBridge plugin files and configured the correct remote Vera IP address in the luup.ip_set command in the startup file, then you should see in the interface all your remote devices bridge to the openLuup system.”
So my question is: How can I modify the “startup file” . I would need some kind of console access wouldn’t I? Can I do this via Docker or should I login separately with SSH?[/li][/ul]

That’s everything so far. Thanks so much Airedale for making the openluup docker image work and ofcourse Akbooer & Amg0 for your great efforts with Openluup and Altui.

Kind regards,


Hi Jacques,

I am glad to hear this has been helpful. It seemed like a lot to get setup and I wanted to make it a bit more straight forward. Akbooer and AMG0 did the heavy lifting for sure!

You have a very early build of the openluup from me. I was going to post more on it once I figured out all of the gotchas, but as of right now it is alpha at best.

The AltUI gets wiped everytime you reboot the docker image because I am not persisting it. I can persist it, but didn’t want to until I had everything worked out. I will get this fixed. I plan on working on it tonight.

Use the same method as with datayours and set your vera ip through the veraips variable. It should work.

Let me make more progress this evening and I’ll post to where I am at.

Also - thanks for pointing out the Synology bug - It is a pain! Why that happens for that one, and not my others, I am not sure.

Hi Airedale,

I fully understand this is still work in progress. Nevertheless it’s great to see where this is going. I am happy to test any future versions and provide feedback.

I am not exactly sure how I can set the veraips variable. I tried via the command line by ssh-ing into my synology box. I also tried via the docker gui but AltUI won’t start this time.

Here is screencopy of my settings.


[url=!107271&authkey=!ACEK1IndXkOusKI&ithint=folder%2cpng]Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

I see where you have the veraips set, and if that is the ip of your Vera, then it should work. I will let you know this evening when I have a build up.

OK - I have updated the image for openluup. Please try it out and let me know what you think.


[ul][li]The docker image should persist the files now on your synology - you do not need to specify any mount point for this[/li]
[li]if you want to push your own startup.lua file into the image, mount the /files directory and put your startup.lua file there. You can also put whatever other plugin files there as well. It will copy them in on startup.[/li]
[li]Example flag: -v /your/host/path:/files[/li]
[li]Everytime you add a new file into that directory, you will need to restart the container.[/li][/ul]

I did some further testing and here is what I found:

The new image works well. I have specified the ip of my ‘real’ vera in the environment variables and when altui starts I get the homescreen populated with all my devices via verabridge. So far so good -:wink:

However I found that the docker image is still not persistent across reboots of the container. Maybe it has something to do with the fact that I haven’t been able to figure out how to configure a mount directory via the docker gui.

I must be doing something wrong here. The log files also state that AltUI cannot find a certain file or directory. See screenshots attached.

Some questions:

[ul][li]Is a mountpoint indeed necessary to make the image persistent across reboots?[/li]
[li]I discovered there is also a console (terminal) window in the docker gui. Can I use this to run certain scripts, e.g. to restart openluup without having to reboot the container?[/li]
[li]Will I be able to update to future versions of openluup or does this require a new docker image?[/li][/ul]

Thanks a lot,


i think we are close - let me test and get right back to you on all of the questions.

Airedale… do you hve a separate thread on openLUUP Docker image?

I’d like to run it on my Syno (DSM 6)… what command do I need to pull it from your repo and install? the repo looks empty… docker pull airedale/openluup

Can you please document variables the need to be set.