DataYours - a Data Storage Provider for AltUI

I have a recent version downloaded from Github (found now over writing my L_DataUser.lua :frowning: )
Still AltUi is not displaying the option to push to DataYours

See Attached

Searching the log for DataWatch:

50	11/02/17 8:57:45.393	luup_log:9: DataYours:  service: Watch - L_DataWatcher <0x765a8520>
50	11/02/17 8:57:45.411	luup_log:9: DataWatcher: starting variable watch... <0x765a8520>
50	11/02/17 8:57:45.414	luup_log:9: DataWatcher: registering with AltUI [11] as Data Storage Provider <0x765a8520>
08	11/02/17 8:57:45.416	JobHandler_LuaUPnP::HandleActionRequest argument newUrl=http://127.0.0.1:3480/data_request?id=lr_DataWatcherRelay&target={0} <0x765a8520>

Which version? Did you download from the Development branch? (that?s the latest)

I used version 2016-10

Latest is 17.9.18, from the development branch…

Updated to dev version:
Still no luck,
Anything else I can check?

50 11/04/17 16:28:21.375 luup_log:9: DataYours: service: Watch - L_DataWatcher <0x77038520> 50 11/04/17 16:28:21.409 luup_log:9: DataWatcher: starting variable watch... <0x77038520> 50 11/04/17 16:28:21.412 luup_log:9: DataWatcher: registering with AltUI [11] as Data Storage Provider <0x77038520> 08 11/04/17 16:28:21.414 JobHandler_LuaUPnP::HandleActionRequest argument newUrl=http://127.0.0.1:3480/data_request?id=lr_DataWatcherRelay&target={0} <0x77038520>

Hoping akbooer can help with this.

Have been a long time user of DataYours on my VeraLite (UI5) and used the remote access frequently to keep a check on things. Many thanks for this wonderful plugin.
Unfortunately my VeraLite died recently and I have now acquired Veraplus (UI7). I have successfully installed DY on it and I’m able to view data stored on my NAS via the DY dashboard. This is fine for local access, but I understand that remote access can’t be achieved in the same way as with UI5. So I installed AltUI and now very much prefer this interface over UI7. My aim now is to remote access my VeraPlus using AltUI and view my DY data.
DataYours was installed from the Vera App store and then the files updated to the latest (from akbooers Github development branch). DY has registered withAltUI and I can select it from the menu when choosing to watch a variable …all good so far. My problem is I can’t see the data in graphical form. I think the Graphic URL is wrong and it’s not finding the data. Hence it’s showing 404 - Not Found. I don’t understand if this URL is something I should be entering each time or if it should pick it up automatically from somewhere. I also get the same message 404 - Not Found when I click on any of the dataxxx config or Graphite metrics index links on the control tab of DY. Please see attachments which hopefully show my problem.

Any help much appreciated.

Yes, I rather suspect that this needs updating after Vera’s recent attempts at ‘security improvements.’

For both the graphic URL and the links to the various configurations, can you try putting /port_3480 in front of them and see if that works?

Wow, that was quick.

Yes, that did it for local access, but unfortunately when viewing remotely it shows ‘ERROR:Module not found:port_3480’.

Any other ideas?

OK, so I need to update the links in the software so that they work locally. I will do that.

For remote access, I can’t really help, it’s simply something that I don’t do. I know that it’s not necessarily straight-forward. I’m not up to speed with the latest methods of remote access for AltUI. Maybe something that you can ask on that thread.

Ok, thanks for your help. I’m nearly there, will try the other thread.

I cannot get the DataWatcher to send data to a different InfluxDB server. Up until now I’ve always had the openLuup on the same RPI as the InfluxDB server which works fine. The openLuup is on .205, the new InfluxDB is on .212. The DataWatcher config looks okay to me - does anything look incorrect?

I can see the .212 InfluxDB starting graphite on UDP port 2004 in syslog. I can’t see this with nmap, but neither can I see it on the .205 server that works. Also, I have “graphite” enabled in the InfluxDB, not the UDP service. However, this is also the same as the working server on .205. See below for the syslog snippet of graphite starting up on the .212 (new) server.

I get nothing in syslog, no errors anywhere that I can find. But the data is not getting to InfluxDB as far as I can tell. The same query does not find the data on the new InfluxDB (it does work for other data stored there via the http interface).

I’m sure I’m missing something obvious, but I don’t know what it is…

Jan  3 19:01:17 chelan-nuc influxd[14178]: ts=2019-01-04T03:01:17.442871Z lvl=info msg="Starting graphite service" log_id=0CmhlVuW000 service=graphite addr=:2004 batch_size=5000 batch_timeout=1s
Jan  3 19:01:17 chelan-nuc influxd[14178]: ts=2019-01-04T03:01:17.442886Z lvl=info msg="Registered diagnostics client" log_id=0CmhlVuW000 service=monitor name=graphite:udp::2004
Jan  3 19:01:17 chelan-nuc influxd[14178]: ts=2019-01-04T03:01:17.443227Z lvl=info msg=Listening log_id=0CmhlVuW000 service=graphite addr=:2004 protocol=udp addr=[::]:2004

Here’s the DataWatcher configuration:

[code]DataWatcher CONFIGURATION at Thu Jan 3 20:39:03 2019

DAEMON = {
VERSION = “2016.10.10”,
client = “DataWatcher”,
destinations = {“127.0.0.1:2003”,“192.168.86.212:2004”},
errors = {count = 0},
http = {received = 7},
ip = “192.168.86.205”,
start_time = “Thu Jan 3 13:22:21 2019”,
udp = {
last_received = {},
last_sent = {
[“127.0.0.1:2003:inet”] = “hvacTime.hvac 0 1546576722”,
[“192.168.86.212:2004:inet”] = “hvacTime.hvac 0 1546576722”
},
received = 0,
sent = 1301
}
}

DATAWATCHER = {
VERSION = “2017.04.17”,
live_energy_usage = {},
memory_stats = {},
tally = {
HTTP_relayed = {
[“EnergyUsage.e”] = 43,
[“IndoorTemperature.temp”] = 76,
[“OutdoorTemperature.temp”] = 8,
[“chelan.kwh”] = 38,
[“chelanMonth.kwh”] = 38,
[“cpu.d”] = 218,
[“hvacTime.hvac”] = 420,
[“memory.d”] = 218,
[“solarGeneration.e”] = 24,
[“uptime.m”] = 218
},
UDP_relayed = {},
watched = {}
},
translations = {[“*.urn:micasaverde-com:serviceId:HVAC_OperatingState1.ModeState”] = {
Cooling = -1,
Heating = 1,
Idle = 0
}}
}

[cache] = {
LOCAL_DATA_DIR = “whisper/”,
UDP_RECEIVER_PORT = “2003”
}

[dash] = {
DATAMINE_DIR = “”,
ICON_PATH = “/cmh/skins/default/img/devices/device_states/”,
LOCAL_DATA_DIR = “whisper/”,
VERAS = “”
}

[graph] = {
DATAMINE_DIR = “”,
LOCAL_DATA_DIR = “whisper/”
}

[mine] = {DATAMINE_DIR = “”}

[relay] = {
DESTINATIONS = “127.0.0.1:2003, 192.168.86.212:2004”,
LINE_RECEIVER_PORT = “”,
LIVE_ENERGY_USAGE = “0”,
MEMORY_STATS = “”,
SYSLOG = “127.0.0.1:514”
}[/code]

We need to know whether the issue is with DataYours or InfluxDB configurations.

The DataYours log shows successful relays of data from incoming HTTP, so I assume that these are coming via AltUI variable watches to DataYours as a Data Storage Provider. This is on a Vera?

Have you tried manually sending a UDP datagram to the InfluxDB instance using the plaintext format?

openLuup and AltUI, no Vera. I haven’t tried the manual UDP. I see that I can use nc for it. what’s the format for the data in this case?

As always, thanks very much for your help.

You’re still using DataYours on openLuup? I switched to the native Data Historian.

Yes, [tt]nc[/tt] is the thing, with the [tt]-u[/tt] option.

Format is simply dataname and value. A final time stamp in seconds is optional.

foo.bung 42

https://graphite.readthedocs.io/en/latest/feeding-carbon.html#the-plaintext-protocol

It’s been working quite well, so I haven’t seen the need to change anything. I would like to figure this current issue out, then I can try moving onward and upward. Thanks for the link on carbon - I’ll try a manual udp and see what that does.

It would be really nice if InfluxDB logged what it is doing for the graphite interface. There is write logging for http, but I don’t see the equivalent for graphite. I can turn on the debug level to see if anything pops out. It’s a bit frustrating where there are no errors or warnings but the data disappears.