Danfoss LC-13 is not working in VeraEdge

Dear Support Team,

I have 3 Danfoss LC-13 and the value of them can not be changed using the software Mobile UI7 App on iphone and ipad. Also I can not change the value using my laptop.

If i change the value on the device locally, so I can see the new value on the software but I can not change the device value using the app mobile ui7 or over my laptop. On the software I can only see the current device value.

If I try to change the value on the software, I can see a green circle rotating for 30 seconds but nothing happens on the device.

Can somebody help?

same problem today. It seems, that the edge can read the data, but cannot change anything.


same here…

Same here. Really frustrating with new Vera Edge. Usb port not working, Danfoss not working, E thermostaat plug-inn not working :frowning: :frowning:

Same here, it will work if i wake up the danfoss manually after editing it in veras UI.

got a reply stating the following

I would like to let you know that I?ve checked the Danfoss devices that you?ve paired with the VeraEdge unit and this issue is reported on our internal tracker and my colleagues from the development team are working to fix it and the fix should be added in the one of next updates.
As far as I know my colleagues in development will release the next firmware update at the end of this week, lately at the beginning of next week.
More information on the release notes for UI7 you can find in the link below:

Same problem. Purchased 5 Danfloss LC 13’s and a Vera edge. testing one first and Vera Edge will detect it if selecting generic z wave, then it finds it as ‘Danfoss radiator’ Beyond that its pretty useless.
I guess the risks of using new technology!
I would appreciate notification of any advancements with the use of these LC13’s with Vera Edge.


The best is that - Danfoss LC-13 works ok on Vera Lite with firmware: 1.7.439. After upgrade in December to 1.7.481 or now to the newest firmware Danfoss doesn’t work.

I experienced the same on my Vera Lite. Worked on 1.7.439 but not on newer firmwares.

any news on your part? I’m still having non responding thermostats. the update didn’t fix this with me

Same problem for me with Veraedge (firmware 1.7.961) and Danfoss LC 12 (works correctly with Veralite UI5). I emailed to support team but no answer.


Support got back to me saying they are looking into the issue and logs and hope it will be fixed for the March sotware update.

I’ve upgraded my VeraEdge to 1.7.1018 but still the Danfoss Radiator is not working !


I’ve upgraded my VeraEdge to 1.7.1018 but my Danfoss Radiator is still not working !


I’ve upgraded my VeraEdge to 1.7.1018 but my Danfoss Radiators are not working !


They do not work on Vera Lite 1.7.541 either :frowning:

I Have 3 SRT-321 thermostats connected to the vera, and i can confirm that changing the setpoint is not working from the web-interface, ios / android app etc. (only way for me to change the set-point remotely is via the imperihome app on android).

I had a support call about this and they told me that they will look into it with the development team, and maybe solve this in a next upcoming software release.

I think this issue has the same root-cause as your problems, so maybe, if we keep mentioning this irritating issue they will fix it eventually…



I’ve upgraded my VeraEdge to 1.7.1089 but my Danfoss Radiators are not working !


I’ve upgraded my VeraEdge to 1.7.1089 but my Danfoss Radiators are still not working…!


[quote=“tomheld, post:19, topic:184614”]I’ve upgraded my VeraEdge to 1.7.1089 but my Danfoss Radiators are still not working…!


Me too !!