CT100 Connections issues - 1.7.830 firmware

Logged a ticket; Will post resolution here (if) for knowledge base. I have four CT100s; 3 of 4 have had no issues since upgrade. One has lost connection multiple times for long periods. I’ll see what support says. I’m guessing exclude/include. I tried to delete and an exclude but it will not delete. Node issue???

Log from a forced poll

08 07/27/16 9:16:43.509 JobHandler_LuaUPnP::HandleActionRequest device: 66 service: urn:micasaverde-com:serviceId:HaDevice1 action: Poll <0x2fc48680> 08 07/27/16 9:16:43.510 JobHandler_LuaUPnP::HandleActionRequest argument id=lu_action <0x2fc48680> 08 07/27/16 9:16:43.510 JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:micasaverde-com:serviceId:HaDevice1 <0x2fc48680> 08 07/27/16 9:16:43.511 JobHandler_LuaUPnP::HandleActionRequest argument action=Poll <0x2fc48680> 08 07/27/16 9:16:43.511 JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=66 <0x2fc48680> 08 07/27/16 9:16:43.512 JobHandler_LuaUPnP::HandleActionRequest argument rand=0.20615039414891 <0x2fc48680> 02 07/27/16 9:16:44.977 ZWJob_PollNode::ReceivedFrame HandlePollUpdate failed job job#5252 :pollnode_sms2 #9 dev:66 (0x1e21e28) N:9 P:20 S:5 got after 1 seconds FUNC_ID_APPLICATION_COMMAND_HANDLER node info for 9 status 0 data 0x5 0x1 0x2a 0x2 0xd5 (##*##) <0x2b626680> 02 07/27/16 9:17:06.822 ZWaveSerial::GetFrame 0x2be25ef0 timed out now 0 m_listGetFramePending 0 <0x2be26680> 02 07/27/16 9:17:06.823 ZWaveJobHandler::SendDataAbort got m_iFrameID 0 <0x2be26680> 02 07/27/16 9:17:06.823 ZWJob_PollNode::ReturnMessageNotReceived -end- job job#5252 :pollnode_sms2 #9 dev:66 (0x1e21e28) N:9 P:20 S:5 node 9 didn't reply iOK 0 iBadTx 0 iNoReply 15 Abort returned m_iFrameID 0 <0x2be26680> 02 07/27/16 9:17:06.824 ZWJob_PollNode::PollFailed job job#5252 :pollnode_sms2 #9 dev:66 (0x1e21e28) N:9 P:20 S:5 node 9 battery 1 notlist:0 <0x2be26680> 06 07/27/16 9:17:06.825 Device_Variable::m_szValue_set device: 66 service: urn:micasaverde-com:serviceId:ZWaveNetwork1 variable: ConsecutivePollFails was: 2196 now: 2197 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x2be26680> 02 07/27/16 9:17:06.826 Device_Basic::AddPoll 66 poll list full, deleting old one <0x2be26680> 06 07/27/16 9:17:06.828 Device_Variable::m_szValue_set device: 66 service: urn:micasaverde-com:serviceId:HaDevice1 variable: PollRatings was: 0.00 now: 0.00 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x2be26680> 04 07/27/16 9:17:06.829 <0x2be26680> 02 07/27/16 9:17:06.830 JobHandler::PurgeCompletedJobs purge job#5252 :pollnode_sms2 #9 dev:66 (0x1e21e28) N:9 P:20 S:2 pollnode_sms2 #9 9 cmds status 2 <0x2be26680>

No response from support yet. BUT what I am observing is that while it says that it is unable to connect to device, when I change a value, it sends accepts and then connects… and the looses the connection minutes later. So, I think this is related to other ‘can’t connect to device’ issues with the latest firmware.

I am having the very same trouble with a single CT100. I have tried unpairing, repairing, doing so with AA batteries in and with them out. Same results. I even went to Lowe’s and purchased a new one thinking perhaps my old one was first gen since I have had it for a couple of years now. Nope same results. I’ll be anxious to hear the results of your ticket.

No ticket resolution yet. They asked me how far the device was from the Vera, and then nothing.

I stand corrected; support did get back to me late Sunday night. Here is what they recommeded. I’ll try tonight.

Hello Paul, Please try to restore a backup from a day when your thermostats worked properly on the system by going to Settings > Backup, then click on ?Restore? with the option ?Restore Z-Wave network? checked. Wait until the unit is up and running and then check to see if there is any improvement. Otherwise, I?ll recommend you trying to include again the thermostats into the mesh Network. To do this, bring your thermostats within 3-5 feet from your Vera Controller. Afterwards access your Vera Web Interface ( Dashboard ), click on Devices > Add Device > Other Device > Other ZWave device, click on the step 3 ( in the right side of the page ) then click on Retry button. Your unit will be into exclusion mode, in the status bar you should see the this message: ?Add/Remove : Remove devices now??, after then follow the steps on your devices for exclusion process according the owner guide. Then automatically the status bar should be: ?Add/Remove : Add new devices now?? if not so, click on ?Try adding it again? to put your unit into inclusion mode, the status bar should be changed into: ?Add/Remove : Add new devices now?? and then follow the steps on your devices for inclusion process according the owner guide. Then give a name to your device and click on the Finish button. Or, for testing purposes you can try to put in the half distance in between vera and your thermostats a repeater device to see if the matter is from the Z-Wave range. If you still have the same matter please enable again tech support on the unit so I can check the settings of the unit. Once tech support is enable, please provide me the access code here.

Paul and anyone else interested,

My VeraPlus is exactly 6 feet, 9 inches away from my CT100 with a direct line of sight between them. Still same results.

Thanks; I might fire off a scene to change the fan to Auto once an hour. At least then it will force the connection and update values once per hour. Until a firmware update is confirmed to fix connection issue.

The scene is working well. Keeps them alive.

Not one connection loss since I added a scene 20 hours ago that runs every 60 minutes that sends one action. Set fan mode to auto. Not sure what this will do to battery usage. Prior to having the scene I would loose connectivity multiple times a day for long durations.

Hi Paul,

I have the exact same issue and would like to try your solution. When I create a scene with the CT100 thermostat, I don’t see any way of controlling the fan. I have the up/down arrows for temperature, and Off/Auto/Cool/Heat buttons.

Are you controlling the fan through a LUA script? If so, can you share the code, please?


It has not worked perfectly as the connection does drop (don’t have stats); but at least it reconnects 1/hr minimum. You have to used the advanced editor; add then thermostat and then HVAC_FanOperatingMode to “AUTO” See attached screen grab.

Aha, that’s the trick! :slight_smile: Thanks for sharing… it seem to work fine, and as you say, at least once an hour the device is there. The connection seem to vanish after a few minutes though, as you say.

I had no issue with the previous version of FW running on my VeraLite. This is definitely an issue with this new FW.

Thanks again for the tip, Paul!

Is there any way to set the CT100 to change Fan mode through a Vera Scene?

I would like to turn the fan off if someone presses the fan only button on the CT100.

My son turned the fan on by accident and it was on all day.

I would like the scene to work this way:

Someone presses the fan on button on the CT100
The Vera, through a scene, switches it back to Fan Auto



I can switch the fan to auto in the scene but the scene does not run if someone turns the fan on. The trigger I used was “Basement Thermostat fan is running”. Not sure why the scene is not triggered when the fan comes on.

I think you need a trigger based on urn:upnp-org:serviceId:HVAC_FanOperatingMode1 = ContinuousOn.


Thanks, the trick is to get the luup code to trigger. I don’t think the vera allows this. The built-in fan trigger does not work.

I recommend buying the PLEG plug in. It has a free trial so you can see if it does what you want. It is easy to set up device properties as triggers. It is super useful.

I sometimes forget which functionalities are only in PLEG because it is my go-to for logic.