Controlling GIRA Funkbus with Vera Plus + RFXcom

I have a GIRA systeem 2000 in my home (Netherlands), which should be able to control with the RFXcom on 433,43 MHz. The RFXcom manager app on my laptop has the “Funkbus” functions in there.

I bought the Vera Plus and connected the RFXcom433E but did not get it to work yet. I cannot find anything on the Vera forums how to control this system. Can someone help me out?


For the RFXtrx433E you need to have the latest version of the Pro2 firmware (1041) installed. With that done you can then go to the Protocol Settings tab and select the 433.42 frequency. Then you can enable the Funkbus protocol.

Additional Info: Unfortunately the plugin does not currently provide the means to add any devices that use this frequency/protocol. I will make those additions in the next version of the code.

I connected the RFXcom and added the RFXcom gateway app. Now I see a red bar with RFXcom saying “can’t detect device”…

The RFXCOM gateway is a very old Vera app and has not been maintained in a long time. The files for the current RFXtrx plugin are attached to the posting in this category: Plugin Update V1.87

OK thanks it worked! I manage to control now some lights (klik-aan-klik-uit) and the fireplace with the Mertik Maxitrol G6R-H3T1. Few observations:

  1. the Mertik control only can run up the fire fully, or stop the fire. There are no settings in between.
  2. My GIRA ligths should be controllable with the ‘Funkbus’ protocol which is lacking in the Vera home control application.
  3. The RFXcom manual states that the Gira should alternatively be manageable with the ANSLUT protocol which exists in the Vera app. But I cannot identify the right ID.

See page 45 of this manual:

Thanks for your help!

Did your system come with its own remote control? If so, have you tried to use RFXmngr with the Funkbus protocol enabled to see what is received when you use that remote control?


Yes it comes with this remote:

I tried to connect the RFXcom directly to my laptop and steer the lights, without success. It seems the RFXcom cannot ‘learn’ the signals of the GIRA remote. Sending signals from the RFXcom did not work because I had some kind of port error in windows…

I’ve looked at the user instructions for the remote. If you’ve configured the lighting controls to respond to the remote then you should know the group and channel numbers that the lighting controls will respond to. You can use those values to create an ANSLUT device from the New Deice tab of the RFXtrx device pages in the Vera plugin.
As for using RFXmngr with your laptop, it works best to connect the RFXtrx transceiver to the laptop before starting RFXmngr. When RFXmngr starts it usually finds the correct USB port when you click the connect icon (top left).


I tried to add a device manually (ANSLUT) but I get the following message: “Vera will reload to validate the changes…” and nothing happens. Also other protocols will not be added manually.

When trying to set the protocols in the RFtrx settings, I get the message ERROR: invalid service.

Also, when adding the L_RFXtrx.lua file in the develop apps I get the following:

ERROR: Internal Server Error

Am I doing something wrong?

Have you uploaded all the files from the zip file in Plugin Update V1.87 ?
I’ve not ever seen the errors you’re reporting.

Hi, I did that before, but apparently there was something wrong. Now I was able to add a device (!) and see the page with the settings. I selected the ANSLUT protocol. But now the options for settings are a bit different then in the RFXcom manual:

Selecting FUNKBUS for the 443.42 MHz:

Selecting the ANSLUT protocol gives this screen:

Now ID and unit code must be selected. Then manual states this:

So the ID that the RFXcom expects is hexadecimal, but there is no way to enter this in the ID field, which expects a decimal number. I have tried to enter the converted decimal figure as well (by online HEX-DEC converter) but that did not work. (For example ID 0 00 3F CC becomes 16332). So I think the ‘New Device’ screen should have these fields as stated in the RFXcom manual.

By the way, when pressing the remote control buttons on Vera, the lights of the RFXcom come up (first red, then green), so it is sending a signal!

If I go to the Protocol Settings page, I also see that the Vera is receiving messages because the ‘last received message’ field changes when I press a button on the GIRA remote control…

So far my experiments (I did not know this was going to be so complicated)… step by step but I hope it will work soon.

Thanks again for all the help.

As I said in an earlier reply in this thread, the plugin does not yet have the ability to add actual Funkbus devices. So configuring the plugin to use the 433.42 frequency will not help to add such a device.
Configuring the transceiver at the normal 433.92 frequency and adding an ANSLUT device as suggested in the user guide allows the transceiver to transmit at the 433.42 frequency when sending commands to your GIRA device.
Using an ID of 16332 for the ANSLUT device should be correct but that assumes that the Group setting is A.
You should be able to use RFXmngr, select the Funkbus tab, set the proper group and channel values (forget about the 3FCC - this is only used with the ANSLUT device settings), and then confirm that you can send various commands to your GIRA device.

Hi, it does not work yet in the Vera, using the ANSLUT.

When connecting the RFXcom to my laptop, in the funkbus tab, the ID is set to default values 00 and 00 with drop down menus. It cannot send any commands if I leave the settings like that. I have to enter something else than 00 00.

When I enter 3F CC in these fields, I get the following error message when pressing the “transmit” button:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.OverflowException: Arithmetic operation resulted in an overflow.
at RFXmngr.frmMain.B9AAA(Object 0AAAA, EventArgs 1AAAA)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 4.7.3460.0 built by: NET472REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/RFXmngr/RFXmngr.exe

Assembly Version:
Win32 Version: 14.7.3190.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll

Assembly Version:
Win32 Version: 4.7.3451.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

Assembly Version:
Win32 Version: 4.7.3429.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

Assembly Version:
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

Assembly Version:
Win32 Version: 4.7.3190.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

Assembly Version:
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

Assembly Version:
Win32 Version: 4.7.3190.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

Assembly Version:
Win32 Version: 4.7.3190.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

Assembly Version:
Win32 Version: 4.7.3190.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

The source of the problem is that you entered values in the selection box, please select the values.

You were right, now the error is gone and I am able to control the lights!! Thanks!

I also found out I have to ‘teach in’ the wall receivers on the RFXcom, then it works. It cannot just take over the GIRA remote signals. This is my setting which works in RFXcom:

Funny thing is that when I do this, I can NOT control them from the Lighting2 ‘ANSLUT’ tab in RFXcom. Which settings should I use here (still not clear to me how to do that… sorry).

Now the next step is controlling them from the Vera app… I think the best would be to have a FUNK device added to the Vera software (which is not yet available as Tinman said). Would that be possible??

So far I cannot find a way to let Vera talk to the RFXcom, controlling the lights (the ANSLUT procedure does not work). I think we need to develop the Funkbus device in order to that… Any thoughts?

To control Funkbus using an Anslut device you need a special firmware which is available on request from support

Hi Bert, thanks for sharing the update. It works now with ANSLUT.