Connecting to a rfxtrx433 via its IP & Port under UI7?


I’m trying to connect Vera to my network connected RFXtrx433 transceiver via its IP and Port *under UI7, however I don’t seem to have the option ? (Compared to what is available under UI5)

  • My USB/Serial RFXtrx433 deviice is connected to a RaspPi that’s running Ser2net to allow it to be accessible over the network…


UI7 - no options at all…

I tried adding its IP and Port numbers under Advanced on the device itself, but that didn’t seem to do anything ?

I think you need to set the IP address in the Params tab. I added the IPPort in the variables tab so there’s no need to modify the D_RFXtrx.xml file. You may want to look at the postings here: RFXTRX433e to VeraPlus via USB to ethernet - #8 by anon37769099 - USB RFXtrx Transceiver - Ezlo Community

Thanks for responding @tinman, I had previously visited the link you posted, I couldn’t really work out what was going .

What/where exactly is the Params tab you are referring to ?

In the Advanced tab of the RFXtrx device - right there with the Variables tab.


thank - I assumed that was what you meant - but I thought it was best to check (just in case you knew of some hidden menu somewhere:) )

I’ve actually had the IP:Port listed in the IP field within the variable tab since i noticed there was no option under the apps/Dev/Serial Port Configuration.

As that didn’t work - I raised the opening post above

Still working in this and leveraging details from the other post @tinman shared earlier, I can see the port listed, in the L_RFXtrx.lua file, which left as is, I assume makes that a hard coded/requirement.

-- Function called at plugin startup
function startup(lul_device)

	THIS_DEVICE = lul_device
	task("Starting RFXtrx device: " .. tostring(lul_device), TASK_SUCCESS)
	local debugLogs = getVariable(lul_device, tabVars.VAR_DEBUG_LOGS)
	if (debugLogs == nil or tonumber(debugLogs) == nil) then
		setVariable(lul_device, tabVars.VAR_DEBUG_LOGS, "0")
	if (getVariable(lul_device, tabVars.VAR_DEBUG_LOGS) == "1") then
		DEBUG_MODE = true

	local ipAddress = luup.devices[lul_device].ip or ""
	if (ipAddress == "")
		local IOdevice = getVariable(lul_device, tabVars.VAR_IO_DEVICE)
		if (( == false) or (IOdevice == nil))
			error("Serial port not connected. First choose the seial port and restart the lua engine.")
			task("Choose the Serial Port", TASK_ERROR_PERM)
			return false
		log("Serial port is connected")
		-- Check serial settings
		local baud = getVariable(tonumber(IOdevice), tabVars.VAR_BAUD)
		if ((baud == nil) or (baud ~= "38400"))
			error("Incorrect setup of the serial port. Select 38400 bauds.")
			task("Select 38400 bauds for the Serial Port", TASK_ERROR_PERM)
			return false
		log("Baud is 38400")
		log("Connecting to remote RFXtrx..."), ipAddress, 10000)

		if ( == false)
			error("Remote connection failed. First connect the LAN RFXtrx to the LAN or start the virtual serial port emulator on the remote machine where the USB RFXtrx is attached.")
			task("Connect the RFXtrx to the LAN", TASK_ERROR_PERM)
			return false
		log("Connection is established")

So, changing my ser2net configuration to make the port 10000 too, it seems to rectify the problem.

10000:raw:0:/dev/ttyUSB0:38400 8DATABITS NONE 1STOPBIT

I’m not sure what version of the RFXtrx plugin you’re using but it’s not the latest. The latest version will use whatever port number (IPPort) you set the the RFXtrx variables tab.

Hi @tinman

That’s good to know as I downloaded the files directly from the mios code site (trunk 153)

Where would I find the latest version as I don’t have a dedicated port field it sounds like you have ?

Yes - that’s a very old outdated set of files. The latest is here: Plugin update Version 1.96 - USB RFXtrx Transceiver - Ezlo Community

All updated to the latest version, and it conveniently knew the port number was still 10000.

Many thanks @tinman