Changing Temp from ?C to ?F in z-wave/Vera lite devices.

Can anyone steer me in the right direction to find out how to change the units that are reported in temperature devices in the Vera Lite? Right now everything is reported in ?C and I cannot figure out how to change it to ?F.

Any help is appreciated.

I think there’s something in Users & Account Info - Unit Settings - Weather Settings - Temperature Format

I have that set for ?F.

What temperature device? Most obey the Vera setting. Are you on ui5 or ui7?

I am using the latest FW with UI7 and it happens with all devices. I have a Fortrez temp for the leak detector, the Nest, and the MultiSensor. They all report the degrees in C.

Had had the same problem, so even though this is an old post someone might like to know how I solved it: By going to Users & Account Info - Unit Settings - Weather Settings - Temperature Format, I changed from F to C. Saved, reloaded the the UI (Crtrl F5). Navigated to the same location again and put back F again. Sensor now display correct unit.