Can't install ether-wake

I have tried following the directions in some other threads about correcting the URL for the package repositories. That has made it possible for me to attempt to install ether-wake, but whether I use the install link next to it on the package list or provide the URL directly to the package in the install for URL section, all that happens is the package list get’s refreshed and ether-wake isn’t installed. Any I doing something wrong, or is that package messed up somehow?

Finally, I tried logging on via SSH. When I do “ipkg list”, etherwake is in the list, but when I do “ipkg install etherwake” I get this:

root@HomeControl:~# ipkg install etherwake Nothing to be done An error ocurred, return value: 4. Collected errors: Cannot find package etherwake. Check the spelling or perhaps run 'ipkg update'

Any ideas?

Oh, the repository URLs I’m using are:

I use wol, and have it greatly simplified by a script. I have it documented at home. I can post the instructions when I get home from work if you’d like. FYI, you have to reinstall it with every Vera FW update.

Any documentation you already have would be great! Can you tell me what URLs you have configured for your repositories, I tried installing a few other packages just to test the ipkg configuration and got the same results, so I think my issue the ipkg configuration.

I actually forget will have to wait until I get home to jog my memory. I download all my packages and keep it locally stored on a USB stick that auto-mounts on the second free usb port on the vera. Then I install them locally. I can attach the wol package with my post as well. it’s very small

That would be great! What ever help you can provide is always great.

Has anyone else been able to install package through the WebIf UI with 979 installed? I notice that this Vera build as a bleeding edge OpenWRT build, so I’m wondering if there are issues with the ipkg support on that build.

Copy wol_0.7.1-2_mipsel.ipk to /tmp then cd to the /tmp dir
Sorry, had to zip for the forum to allow an upload
here is the I/O from the shell

root@HomeControl:/tmp# tar xzvf wol_0.7.1-2_mipsel.ipk
root@HomeControl:/tmp# cd /
root@HomeControl:/# tar xzvf /tmp/data.tar.gz

Now Edit your /etc/hosts and /etc/ethers to include hostname, IP address, and mac address in their respective files. You can also use the web UI to do this.
Now create a new file called “wake” and paste the following script from between the rows of asterisks below

if [ -z “$1” ]; then
echo Usage: $0 hostname

sucky_resolve () { grep -i $1 /etc/hosts | awk ‘{ print $1 }’
sucky_ether () { grep -i $1 /etc/ethers | awk ‘{ print $1 }’
broadcast_ip4 () { echo $IPADDRESS | sed s/.[0-9]*$/.255/

IPADDRESS=sucky_resolve $1
ETHER=sucky_ether $IPADDRESS

Now set the executable bit of the new “wake” file
#chmod +x /usr/bin/wake

You should be able to just issue the wake command with hostname after it
#wake nasbox

Good Luck

tt55du, your my hero. That worked great!

For those reading this thread later. In my experience the file to run chmod on and then use in your script was actually called “wol” not “wake”. Also, it does look like there is an issue with ipkg on this build. I tried running in passing in the path to the local .ipk file and it errored out saying there was zero free space which wasn’t the case.

no problem, this one was a pain until I got it working too, glad I could save you some time.

btw, “wake” is just arbitrary, you can call it what ever you want. I would avoid wol as the file name since wol is the actual command, while “wake” just short circuits the esoteric flags and MAC addresses to make it easy.

I think the zero free space is just a matter of how WRT is partitioned with the intent to minimize writes to the flash memory to increase the max read/writes of it. So I was stuck installing it to /tmp which is probably a portion of RAM. I had zero luck with the package manager. Until I stumbled on how to explicitly install ipkgs in this forum, my original plan was to script the install of each ipkg from a mounted USB stick to /tmp of the packages would recreate themselves after any reboots.

just remember to do this each time after a micasa FW update.

Oh, I misread your instructions about creating the “wake” file. I thought maybe you had uploaded a different version of the package then you had used. Now I see that is the name for the script. Thanks again.

I have just added the Wiki page to address the issue of installing extra OpenWRT packages: