Cannot log on locally - Vera Secure

Please help me debug why I cannot log into a VeraSecure from a computer on my network

I load:
It loads and displays my device with a green “Connect” button but clicking it gives a message that states:
Trying direct connection - redirecting to controller
that appears to loop and never connects.
I can connect to the device from my Android App.
The webpage above lets me see that my software is up to date.
Thanks in advance for any assistance you can provide.

It’s probably ad blocker or security software in your browser. I fought with the same problem until @rigpapa tipped me that he had the same issue. I assume you can reach the Vera by using the local IP address?

I had the same issue and found I needed to allow the website in my DuckDuckGo Privacy plugin for Chrome.


Ran into this issue today. @Chadster post solved the problem.
Thanks for posting !

I’ve been seeing this problem for weeks, can seems to solve it.
@SweetGenius can you link to the post that solved the problem?
Edit, nvm saw that it was this post right here.