cannot get foscam to stream remotely

I am having a hard time trying to get my Foscams to remotely stream.

I have been trying to make sense of this:
http://wiki.micasaverde.com/index.php/Remote_Camera_Streaming

I have tried all kinds of variations of forwarding on my router.

My router asks for a port “from” and “to” I have tried putting 3482 into both of these and have tried different IP addresses.

I am using a Linksys with DDWRT

any help is greatly appreciated.

Do you mean streaming through Vera, or the web browser interface?

through Mios

If you have the .Jpeg working, (UN, PW, IP & port set correctly)
Add: %2Fvideostream.cgi into the DirectStreamingURL box and hit save.

JOD.

[quote=“JOD, post:4, topic:169279”]If you have the .Jpeg working, (UN, PW, IP & port set correctly)
Add: %2Fvideostream.cgi into the DirectStreamingURL box and hit save.

JOD.[/quote]

jpeg is working, %2Fvideostream.cgi is in the url box.

I can stream ok when i am browsing from my own network but not when i try to stream from another network 9Starbucks etc.)

I guess I am having trouble trying to set my port forwarding correctly.

It needs to be in the DirectStreamingURL box, but I’m guessing that’s what you meant.

I can stream ok when i am browsing from my own network
Through Vera a browser or the camera software?
I guess I am having trouble trying to set my port forwarding correctly.
Check that your IP:Port setups in the camera, Vera and your router all match. Port 80 is the factory default for this camera.

JOD.

It needs to be in the DirectStreamingURL box, but I’m guessing that’s what you meant.

I can stream ok when i am browsing from my own network
Through Vera a browser or the camera software?
I guess I am having trouble trying to set my port forwarding correctly.
Check that your IP:Port setups in the camera, Vera and your router all match. Port 80 is the factory default for this camera.

JOD.[/quote]

Yes, it is in the “DirectStreamingURL box”
I can stream through vera browser when I am on my own network but not on another network. and it works through the camera software too.
They are all set to port 80.

Do i need to forward port 80? that is open already. I have been trying to forward port 3482 in every way i can think of.

I am still unable to get the streaming to work through Vera from a remote location. I hooked up through my neighbors network on one pc and my own on the other so i can test what i try.

I have tried everything except for what works. disabling router firewall. tried all kinds of port forwarding

When I go to “stream” on the “setting” tab the “up/down/left/right/zoom in/zoomout” buttons appear but no picture. The buttons also control the camera on this tab (“settings”

thanks for any input.

Are you able to view the camera image remotely via a browser and the Foscam software?
If you checked the box while setting the camera up, a power cycle of the camera will email you the link.
If you don’t get an image, that should rule Vera out (for now) as being the issue.
If you do get an image via the browser, hmmm…Double check the Un, Pw, IP & port in Vera, which I’m sure you’ve already done…

I re-read your 1st post about port forwarding. Make sure you set the same port in the camera, Vera and your router.

JOD.

Hi and thank you very much for responding and offering input.

I have not tried that but will work on it now, especially since there is probably more support to do that than here .

If you checked the box while setting the camera up, a power cycle of the camera will email you the link.
what "box" what "link"?
I re-read your 1st post about port forwarding. Make sure you set the same port in the camera, Vera and your router.
So if the Foscam port is "80 by default then do i just input the ip:port in Vera and forward port 80 in my router?
what "box" what "link"?
See screen shots. If you have checked the box to send you an email, anytime the camera is power cycled, you will receive an email with the MAC/IP/port URL. Something like this:[code]000DF6K28372(Cam 1)'s url is http://59.133.18.127:56[/code] The camera's have a built in server and it's the area you need to access to enter a UN/PW, static IP & port. DHCP is the default along with port 80.
So if the Foscam port is "80 by default then do i just input the ip:port in Vera and forward port 80 in my router?
You would need to port forward 80 to the camera, which if it's DHCP, you may be changing the router's rules each time the camera is power cycled. I suggest you set the camera to a static and change the port.

JOD.

Thanks JOD !

I am able to view the streaming camera from an outside/remote network using the Foscam GUI/software but am still unable to get it to stream using the MIOS interface.

OK, at least you know it works. so now we know the problem is within Vera’s setup (who’d a thunk that? ;D) there are two area’s for Vera that accept the Username & Password (one area fills in the other, I forget which) but only one works so double check both areas are filled in and correct.

One area under the Settings tab, the other under the Advanced tab. See screen shots.
Confirm your IP:port is correct.

Fingers crossed you’ll be all set.

JOD.

I had the same issue and now it’s suddenly working. What I did was putting the camera on ethernet cable instead of wireless. Give it a try, atleast in the name of science ;D

tried that. thanks

[quote=“JOD, post:13, topic:169279”]OK, at least you know it works. so now we know the problem is within Vera’s setup (who’d a thunk that? ;D) there are two area’s for Vera that accept the Username & Password (one area fills in the other, I forget which) but only one works so double check both areas are filled in and correct.

One area under the Settings tab, the other under the Advanced tab. See screen shots.
Confirm your IP:port is correct.

Fingers crossed you’ll be all set.

JOD.[/quote]

All that stuff looks fine. I even tried crossing my fingers but no luck :frowning:

Could the Luup file (from the panasonic file) I made be the issue?

Could the Luup file (from the panasonic file) I made be the issue?
I doubt it, but to test, just remove the reference to the file. I'm tapped out on additional suggestions and at a loss as to the problem.

Sorry… I’ll keep thinking.

JOD.

[quote=“JOD, post:17, topic:169279”]

Could the Luup file (from the panasonic file) I made be the issue?
I doubt it, but to test, just remove the reference to the file.
I’m tapped out on additional suggestions and at a loss as to the problem.

Sorry… I’ll keep thinking.

JOD.[/quote]

thanks JOD i really appreciate your help. This place is almost a ghost town and it is nice when someone tries to help out.

not the Luup file.

Are we sure that it is Vera or could it be my router letting the Foscam ap remotely access the camera but not through vera?

Just the reference under the Advanced tab is enough.
I’m not sure about anything now, but If your router lets you through with the Foscam app, I doubt it’s blocking for Vera since the destination is the same, but maybe some network guru’s can chime in…

Another thought. My router uses Mac addresses for port forwarding, are you using port forward to the IP or the Mac?
Are you only using the IP:port and not the Mac within Vera?

JOD.

Is the camera plugged in to your Vera or to the router?