Can we set Vera as a wireless Bridge? or wireless repeater?

Hi All,

I spent several hours setting up Vera and almost there…may be :slight_smile:

I already have a wireless router at home on my 1st floor.
I want to set up Vera on the second floor and do not want to run Cat5 wire from my existing wireless router on 1st floor up to second floor.

Is there a way that I could set Vera to connect with my wireless router via its wireless 802.11g link?

I found information in Wiki to setup Vera as bridge but require CAT5 connect to WAN port from existing router. I followed the instruction to set it up as bridge. It works fine. However, as soon as I disconnect the CAT5, Vera seems to get lost…I could not get to setup screen via its wireless link after that

I could not even login using either :’( Help! Help!..

Thanks in advance

I actually did this last weekend and it worked beautifully. I can say that vera functions very well in client mode. I did not try connecting wired devices to vera’s switch ports, but I imagine it functions fine since vera herself was working ok.

Read this page in the wiki first:

Then go to vera, go to the “Advanced” button, then go to “Net & Wifi”. Here you will find all of the settings to enable client mode.

You will want to enable veras wifi, make sure she can connect successfully to your existing wifi network. Then you can enable client mode. During vera’s restart after enabling client mode (called bridge mode in the menus I think), make sure to remove the wired connection to your existing network so that it does not get confused and see vera both wired and wireless.

Thanks for the fast reply BOSSTON and hope jtran_vera will get this done reading that.

I tried this too (wireless bridge/client mod) today and it worked like a charm. Vera’s WAN port is now unplugged and using wireless WAN - connecting through my WRT350N Linksys router. very COOL!

This may be helpful for folks with distance issues between their wired WAN and their first Z-Wave device closest to Vera. Doing this allows you to move Vera closer to the device and still maintain connectivity. This may help me too if some clients have a similar issue

Thank you so much. This is an amazing forum. I will try it tonight …wish me luck ::slight_smile:


Ok, I had to download latest Luup to be able to follow the instruction that Bosston mentioned in his email. My 2 weeks old vera box did not come with latest Luup ???

Anyway, after I got latest Beta Luup, I selected the option “Through a wi-fi access point. Vera is a bridge”…Vera saved then reloaded…I disconnected WAN cable…VERA came back and nothing…I still could not connect to internet and vera power light stay blinking

Any suggestion? I stayed until 2:30AM last night :’(


Luup is a BETA… Not an “official” release… So I doubt any units would ship with it right now… plus there is sure to be a small supply of older units that haven’t been updated with all the latest out there in the various vendors’ warehouses.

did you select a wifi connection and place a wep key if used

Thanks for replying…

I changed my security to WEP and passphrase on my main router. Then I selected the bridge mode from Vera and let vera did the scanning. It found my main router and asked for pass phrase. I entered the same pass phrase. I saw vera change it SSID to my main router SSID and channel and passcode. It then saved and reloaded …
I disconnected WLAN cable then vera came back with the power light blinking…
I could not connect to vera. I reconnected to vera directly, then set back factory default setting, then when over the same procedure…few times >:( Not getting any better result.
Is there any other thing that I could try? is there a voice support line that I could get help? I am stuck …

Thanks much for helping.

Maybe you can go into your advanced settings and see if everything is setup the way it’s suppose to be. The way we used to have to set up wifi client mode before the most resent firmware.

Step4. Go to Advanced -> Net&wi-fi -> Advanced Configurations
If you haven’t setup any users, login with root ( by default there is no password)
Step5. Go to Network -> Wireless
Step6. Wireless Adapter wl0 Configuration
Set Radio to On and Channel to Auto
Step7. Wireless Virtual Adaptor Configuration for Wireless Card wl0
Set Mode to Client
Set ESSID, Encryption Type, according to your existing wireless network
Step8. Press Save & Apply Changes
Step9. Save changes on Net&Wi-Fi page.

If you end up using WPA2 encription it will tell you that you need to install somthing to make it work but it’s already in there so don’t worry about it. If all esle fails try it with no encription first.
Mine was set up in .616 and when I did the upgrade to .979 it worked perfectly.

Even easier, turn of WEP/WPA and try it, does it work? If so, you know it’s a Wireless encryption error…this should save you some time in troubleshooting. This was brain dead easy for me, it took maybe 10 seconds. I had Vera using a Static LAN IP behind my Linksys WRT350N before I did this.

Had some times last night to work on this. I disable WEP encryption and it worked. I added encryption then it failed. But at least I knew that it could work. I just have to play with different encryption schemes.

BTW, I also just received couple more z-wave modules…it will be a few more late bedtime for me this weekend…

Thanks for all the good suggestion.

I am using WPA and it works fine, might want to consider changing your security.