Can I stop Blue Iris Alerts using a PLEG condition..?

I have 4 outdoor camera’s (HikVision’s) all connected back to Blue Iris, all working great. I have alerts on all four set up to text me with an alert and a still image as well as capture 10 seconds of video and email it to me. All this works fine except it does all of this when one or both of us are home, which I don’t want. I’m using iphone locator so I could use that to confirm that someone is home. When either of us is home I would like NO alerts but when we are both gone turn alerts on. Is that possible…?

you can use this LUUP code in a scene or PLEG to change profiles in blue iris

luup.inet.wget(“http://192.168.1.81:81/admin?profile=2&lock=2&user=USERNAME&pw=PASSWORD”)

I have a something in PLEG setup so when me or my wifes phones are pinged it changes the blue iris profile and vice versa when not pinged

Yup I do the same. I have 4 Profiles in Blueiris

Home Night
Home Day
Away Night
Away Day

And use pleg based on night and day and home or away to change the profiles.

My motion detection stuff is mush different at night then during the day and same with home/away

I also do want some motion recording outside even if we are home and I use PLEG to filter out unwanted notifications.

So if no one just got home in the last 5 min, no exterior door has been opened in 5 min then arm the outside motions. If the door was opened and we are outside playing in the yard the motions and door all need to be untripped for more then 5 min straight. If we keep tripping them they keep resetting the time. I use Vera Alerts and PLEG to do all this logic so I don’t have BI send me the notifications or pic I use VERA alerts (which is also what handles all my other notifications so I keep it all in one program).

Finally getting around to trying this and I’m not getting it to change BI profiles, here is my command set

luup.inet.wget(“http://10.0.1.20:81/admin?profile=1&lock=1&user=RichardPHarvey&pw=xxxxxxxxxx”)

When changing a profile do I change both the “profile” and the “lock” values to the profile number I’m looking to change to…? In the above case profile 1

I believe so. Is your blue iris running on port 81 as well? The :81 after the IP address is port .

[quote=“RichardPHarvey, post:4, topic:191206”]Finally getting around to trying this and I’m not getting it to change BI profiles, here is my command set

luup.inet.wget(“http://10.0.1.20:81/admin?profile=1&lock=1&user=RichardPHarvey&pw=xxxxxxxxxx”)

When changing a profile do I change both the “profile” and the “lock” values to the profile number I’m looking to change to…? In the above case profile 1[/quote]

No just the profile number.

Lock stays at 1

Hmm…so something is still not right. Can’t get the profiles to change at all with that command, even with putting just the http:// part on a browser address line.

you may need to set the blue iris authentication to Non-LAN only, its under the web server tab in options

With his user and password in the string he shouldn’t need that but unchecking it would provide another test atleast. The one that you for sure cant have checked it to the right of that “Secure Only” nothing but the Blueiris Official app will work if that is checked.

Thanks guys, I will check that out tonight.

Yep, the “secure only” box was checked by default. Works now …! As always thanks for the help, you guys are the best.

That will kill alot of things as that forces a security check that only the official Blueiris app has built in. This keeps only a secure connection between those two devices if checked. When that box came out I think in the first release of v4 it created alot of people to have issues connecting with vera for everything from picture viewing to http commands.