Beta feedback Ezlo Plus

Unable to remove users from notifications
If i click on individual buttons to remove who should be notified, they do no work, disarmed or armed.

Just for information, for me changing the notification works well. Using 7.50.622. Tested for EzloPlus and for VeraPlus. Phone is on Android 10.

Since last firmware or app update this is the only thing I see of my Eurotronic Spirit thermostats:

It seems with every release this gets worse. At the beginning these thermostats were correctly displayed and could be used with the app/scenes. Then I couldn’t set them via app. And now in addition not even the temperature is displayed anymore.

1 Like

I have been experiencing the same issue. Seems like we have gone a long way from it working with niggles, to being redundant. I have gone back to my Vera edge and it’s not different. Questioning the system as the moment. :frowning:

Yesterday my Ezlo Plus went offline and unresponsive. Rebooted 2 times to get it back up but now my temperature sensors changed to Fahrenheit. Normally I use MiOS app (iOS) for Ezlo but switched to Vera beta app and was prompted to set timezone, changed to GMT+1 and rebooted but sensors still show temp in Fahrenheit.
Tried to change scale to Celsius via API tool but no luck.
Anyone else having this issue or can @Oleh help me change them back to Celsius?

EDIT: Managed to change scale via API tool with:

{
“method”: “hub.setting.value.set”,
“id”: ID",
“params”: {
“name”: “scale.temperature”,
“value”: “celsius”}
}

Hi @Crille,

I noticed the same. Not good they push an update without publishing release notes. The hub has settings for this, but previously where not used. The Andriod App has not yet been updated to set them, so you have to use the Apitool

Set temp units to celcius ( other value is fahrenheit)

{
  "method": "hub.setting.value.set",
  "id": "_ID_",
  "params": {
    "name": "scale.temperature",
    "value": "celsius"
  }
}

To set the date format to ddmmyy

{
  "method": "hub.setting.value.set",
  "id": "_ID_2",
  "params": {
    "name": "date.format",
    "value": "ddmmyy"
  }
}

Set 24h time format

{
  "method": "hub.setting.value.set",
  "id": "_ID_3",
  "params": {
    "name": "time.format",
    "value": "24"
  }
}

Check the settings

{
  "method": "hub.settings.list",
  "id": "_ID_4",
  "params": {}
}

Cheers Rene

2 Likes

Thank you, missed the date and time format change. Going to fix those too.

Strange, I didn’t notice this change my temperature setting was and still is Celsius.

Edit: I unplugged the Ezlo Plus and that actually forced the upgrade…

Hi @ranneman,

It comes with this release 2.0.6.1271.3. It got pushed to my H2 this morning.

Cheers Rene

Yup just forced it by restarting the unit…

And now the Mios app doesn’t show the firmware version anymore.

iMarkup_20201230_132213

I’m not sure but I think I had a time zone selected which is not visible anymore. I had a test scene running switching on at 6:30 CET. Any idea on setting the time zone.

Maybe these commands can help? https://api.ezlo.com/hub/time/index.html

Interesting, thanks. I used the hub.time.location.set to change location to Amsterdam. As a result the hub.time.location.get indeed shows Europe/Amsterdam. However the Mios app still doesn’t show it. No problem I have tested time based scene and that works fine.

Guys, the release notes for the latest released build:

@Crille,
In the latest build we integrated Temperature Scale Settings.
The default scale is Fahrenheit now.
Also please note that the UI support for this feature will come at a later time with new mobile apps release.
The best way to switch between F and C now is API request.

Power cycling of the Ezlo Plus is forcing the upgrade.

Yes, its the build we released yesterday and has integrated Temperature Scale Settings. The default scale is Fahrenheit now.

@ranneman, thanks for description.
We are checking this issue with app teams.

Also checking this issue with app teams.
For now the best way is to use API requests.

1 Like

I just tried adding a GE3010 in-wall smart dimmer to my Ezlo plus, with the following results:

  • First attempt was just scanning the barcode from the device. This appeared to work perfectly - except the device never actually showed up in the devices list. Fail.
  • Second attempt, I found the GE3010 in the add devices list, and ran through the wizard. It detected the device, started to add it, then asked me to scan the barcode. Which would have been fine, except it didn’t activate the camera so I could scan the barcode. Then my finger slipped, the app somehow wound up at the Alexa VOI screen, and I couldn’t get back to the add device screen (though the top of the app still showed a blue bar). Fail.
  • Third attempt, the device apparently had actually added after the second attempt, but didn’t appear to be functioning as expected (see issues below). On the thought that I had messed up the adding, I removed the device (which worked as expected), then went through the wizard again. This time it added as expected, and showed up in the devices list. Success!

Well, mostly…

A couple of issues still remain:

  • when turning the light off from the app (using the on/off switch), the light does turn off as expected. However, the app shows 66% dimming and “on”.
  • Telling alexa to “turn on the lavatory light” or “turn off the lavatory light” gives a “Lavatory light does not support that” response - clearly incorrect. Asking for a specific dim level does work, however, EXCEPT:
  • Requesting 0% from alexa (turn off) results in a “Lavatory light is not responding” response from Alexa. Even when a request for 1% five seconds earlier - and a request for any other level immediately after - works as expected.

So, all in all, not a great experience. Would it make sense to exclude the device and try again from the top? I’m not hopeful, but I could certainly give it a shot if it might help.