Beta - Ezlo Linux v.1.4.1055.9 update for VeraEdge and Ezlo Plus controllers

We’re releasing today a new Ezlo Linux v.1.4.1055.9 for Ezlo Plus and VeraEdge running Ezlo Linux firmware.


  • Added support to apply predefined settings for LTE Module


  • Fixed reading of ICCID of Sim cards
  • Bug fixes on working with Zwave and Zigbee devices.

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state

  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)

  • Issue with incorrect sunrise/sunset time for scene in case the timezone is changed after enrollment. The sunrise/sunset scenes are calculated based on location and for the moment we do not have UI support to change it after enrollment (API is in progress of being integrated in UI)

  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF

To get your controller updated to the latest version please do one of the following actions:

  • Power cycle your Vera Edge / Ezlo Plus controller or
  • Unplug the ethernet cable, wait for 10s, plug it back into the Vera Edge / Ezlo Plus controller.

This update made my virtual switch on Ezlo Plus stuck in “On”. Can’t turn it Off in iOS MiOS/Vera beta apps or by API.

Edit: No virtual devices is working. Looks like they change state but item.list from API tool shows nothing changed and reopening the app switches them back to previous state.

1 Like

Thank you @Crille for your feedback. I informed the team and they are looking into this as we speak :slight_smile:

I’ll inform you once I have more information.

1 Like

not sure what happened, but now all my VOI connections are missing from the app and any time i try to add it, it goes to a screen that says “select the system you want to connect to the smart home”, but gives me no options to select alexa or google home. i’ve deleted the app and reinstalled. may need to reset the ezlo plus to see if that helps

I’ve had VOI issues from the start, I successfully added both but after unlinking both stay in the app and I can’t relink. It says successful of I try but neither actually do.
If I try to delete without unlinking they also stay in the app.

Hello guys,

Unfortunately we encountered some issues on server side. The VOI service will be temporary unavailable.

We are sorry for the inconvenience.
We will keep you posted.

The day this update was released my Ezlo Plus was no longer reachable even though the app status was green. I power cycled the device and it was reachable again. It seems something during firmware auto-update goes wrong. This is the second time that happened.

Hello guys,
The VOI Service is live again.
Could you please check if you still have issues?
Thank you

VOI seems to be working.

1 Like

Yes, VOI is working again.

1 Like

still not working for me. when i click to add a home assistant it still goes to a blank page that reads “Select the system you want to connect to the smart home” that has no options.

Could you please tell me the app version you are testing on?

sure. 3.46(6)

Ok, I just pushed 3.48(3) on test flight. It has a config change that should fix what are you describing.
Could you please test again after update and let me know if is ok?
Thank you

yep, that fixed it for me. thank you!

1 Like