Beta - Ezlo Linux v.1.4.1055.13 hot fix for VeraEdge and Ezlo Plus controllers

We’ve release a hot fix for the Ezlo Linux firmware v. 1.4.1055.13:

  • Fixed the issue with not being able to operate/control device items
  • Fixed the issues affecting automatic detection of 4G/LTE module.

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state

  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)

  • Issue with incorrect sunrise/sunset time for scene in case the timezone is changed after enrollment. The sunrise/sunset scenes are calculated based on location and for the moment we do not have UI support to change it after enrollment (API is in progress of being integrated in UI)

  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF


Confirmed: Virtual devices are now working again.

1 Like



I’ve just rebooted my Ezlo Plus and its now running this firmware version.

There seems to be a display / refresh problem in the Android Vera mobile app V7.50.529.

For example in the devices area if I turn on a virtual TestBulbRgb or TestDimmer device by pressing the little slide button next to it sometimes its status in the app doesn’t change, I have to drag my finger down from the top to refresh the page manually and then I can see the device I turned on is then showing as turned on.

However this is intermittent sometimes I have the problem I described but some times it works OK and the devices status does change right away after turning it on with the slide button.

The app says its connected Locally.

Same with the TestDoorLock virtual device, sometimes pressing the slide button on that device, the GUI does not update and change the status of the device until you manually refresh the app.

The TestGarageDoor virtual device, pressing the slide button to change it to “Open” does nothing even after a manual refresh its still showing as “Closed”.

App is generally very slow with delays and spinning circles for extended periods of time after pressing something.

Also the Open and Close buttons on a virtual window covering device doesn’t seem to work at all or change the percentage slider for that device.

The Up and Down buttons do appear to be working on the Window Covering device and step in 5% increments.


I will now be requesting ticket numbers for all bugs I report in these forums.

So if this bug is replicated and logged in to your internal system, please provide me with the ticket number.

Confirmed. The unit functions again. Thanks! :slight_smile:

1 Like

iOS or Android app ?

iOS or Alexa. The issue I’m referring to - and I assume that statement in the release notes was referring to - was that the controller could not control devices (i.e the problem was in the controller firmware, not the Controller app). It was receiving the command fine (if I read the logs correctly - maybe it was having problems decoding the command though), but it was unable to control devices.

I haven’t seen the issues you reported with the Android app on the iOS app, so that may be an app issue? Of course, since it only started with this firmware update, there is apparently some firmware involvement at least…

Thanks for confirming.

Started some testing with Neo Coolcam door sensor , no issues detected.
I also added Fibaro dimmer 2 and the inclusion took the entire minute, not sure if this is normal. After this I saw the dimmer but in addition I saw heat sensor, is this normal?
I set one of the module parameters, it worked but isn’t so intuitive compering to the VeraPlus WEB.

Last test I did was to turn off the light a minute after the door is closed and all went good.

I will see if I have other unused modules.


1 Like

I’ve noticed that the ezlo plus only updates its beta firmware by power cycling it, instead of the normal disconnect of the Ethernet cable for 15 seconds.

Is that the expected behavior?

I’ve seen the same, in fact, when a firmware update is applied, the unit doesn’t respond at all until the powercycle takes place, so no scenes run, which is very annoying!

I typically logon to the hub and enter the reboot command. Does the update in about a minute and all runs as expected so far.

Cheers Rene

1 Like

Good to know. It would also be nice if there were some consistency among the various controllers, and/or explicit instructions from ezlo staff for beta testers to follow.

Hi @cw-kid, thank you for sharing this.I’ve passed your feedback to the Android team and our QA to test this use-case. I’ll get back with info when I get an update.

It should work with disconnecting the ethernet cable as well, but looks like 15 seconds are not enough. I’ll test in the next fw upgrade to see how long you need to wait when the ethernet cable is removed for the unit to do the upgrade (I’ve done the power cycle until now).

Update: One of our developers removed the ethernet cable for 15 seconds and the unit got the new fw version. @LibraSun I’m not sure why it didn’t work in your case, did you do the power cycle already?

This issue should have been solved by this firmware hot fix v.1.4.1055.13. Can you please confirm that it doesn’t happen anymore?

I had tried (3x) to force the f/w update by unplugging the ezlo Plus’ Ethernet cable for 15+ seconds (using a timer I set on Alexa, for repeatability), which together with my manual delays, would have been about an 18-second disconnect at most.

None of those attempts resulted in a f/w update. Only the power cycling did. In the future, I’ll try even longer Ethernet disconnects and report my results.

Thanks for the tip!

P.S. In the future, should I look for some indication with the front LED light to signal that I’ve held the Ethernet cable out long enough? I noticed it remained white throughout my earlier attempts. Should it change color? Go out? Blink?

1 Like

thank you for testing and sharing your results.
We’ve also tried now multiple times and here are our results:

  1. 15 seconds is enough
  2. 15 seconds is enough
  3. 15 seconds is NOT enough
  4. 20 seconds is enough

Looks like 20 seconds should be enough.

1 Like

I don’t recall it happening for 1088, but will confirm for the next fw update.


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules