Beta Android - v.7.40.348

Same for me, still have 7.40.347
Update: the 7.40.348 just appeared in the store. Updated and it seem to work correct

1 Like

@kwieto it seems like Google shows updates randomly in the store.

@Odysee try to check the update maybe later today.

Just received mine.


The update is available now and the crash from the device tab is gone :+1:

1 Like

I got mine too, thanks.

1 Like

I just received this new version.

Unfortunately, it is not working properly on my device (Moto Z2 Play, Android 9.0).

Is there some recommended series of activities or test runs you guys want us to try with the beta app? I’m all ears.

I’m such a Web UI-centric guy that I virtually forget there even is a Vera Mobile app, much less use it on a monthly (or even annual) basis. So some beta-specific requests are very welcome!

  • Libra

Hi @LibraSun!

It would be great if you use all new features which we have been adding in the app.
If you haven’t used Ezlo VOI™ you should definitely try it :slightly_smiling_face:

We also have a new Ezlo App. The Ezlo app you can use in parallel with Vera app, if you have Ezlo Atom or/and PlugHub.

Thank you! And waiting for your feedback!

1 Like

Just to be clear, Ezlo VOI™ requires that I have an Atom or PlugHub, right? (Because I own neither, so had not even looked at it)

Yes, you need to have the Ezlo Atom or PlugHub.

On looking at the beta Vera Mobile app, I notice that lots of ‘Notifications’ are being included under ‘Scenes’, which I would not normally expect to see.

For instance, all of my “Battery Low” and lock-related (e.g. “Wrong Code Entered”) warnings appear there – which is neat in a way, since I normally have to visit each device individually to edit these, or to be reminded they exist! – but should they be called ‘Scenes’?

I’m thinking users would be better served if these non-Scene items got lumped into a separate area, called “Notifications” instead. Since that is their intended purpose, after all, plus nobody would ever ‘Run’ these manually or via voice command, as they would with “Scenes”.

  • Libra

As a follow-up to the above, I took the liberty of using the beta app to (a) create a new room “_Notifications”, and (b) assigning a couple of those “No Room” faux scenes to the new room.

After a refresh of my web browser, back on the Vera UI, I noticed this (correctly) causes the moved Scenes to appear and thus become editable from the UI instead of only in the app. That’s a neat “feature” in that it gives users the chance to add lots more events than simply a notification, whenever a “Battery Low” or similar trigger fires.

However, even once these formerly “hidden” Scenes are surfaced in the Vera UI, there is no explicit way to determine which device they are triggered from, since they contain no Device Action(s) or Lua code; you have to rely entirely on the name originally given to it, and hope that sufficiently explains why/when it will run.

P.S. I assert that this adds even more weight to my recent suggestion in “Feature Requests”, that users ought to have a way to “Hide” entire Rooms, or device Types, in the UI – and have those settings persist across multiple visits and be mirrored in the app, etc. – since things get cluttered FAST otherwise!

BUG REPORT: New Scene created in app fails to appear in Vera UI

Today, on a whim, I created a brand new Scene (called 'Test Entering Home Space (#86) – assigned to ‘No Room’) in the beta app, then checked my Vera UI hours later when I got home.

The new scene does NOT appear anywhere under ‘Scenes’ in the UI, but I can confirm it resides somewhere in Vera because I see 'Test Entering Home Space" in the drop-down list Reactor shows me when adding a [Run Scene] action under Activities. It is shown as being assigned to (no room).

Looks like a bug to me. (Make that two bugs … see Update #2, below!)

  • Libra

UPDATE 1: I can further confirm, after using the beta app to assign the Scene to a different room ("_Zzz"), that it still does not appear in the Vera UI – despite multiple restarts of the Luup engine during testing. Nevertheless, the room assignment appears to have been successful, since once again I can see it listed in Reactor as residing in room “_Zzz”. I will report back with any further findings.

UPDATE 2: On closer inspection of the affected Scene, using the beta app, I notice that it consistently “forgets” the Immediate action (turning on a single Hue light bulb called ‘Fireplace’), thus appears to do nothing when run. Twice I attempted to ‘Edit’ the Scene, specifically editing the list of devices under ‘Immediately’ so as to include ‘Fireplace’, and in each instance, the edit does not persist.

UPDATE 3: Wondering whether the app was causing Scenes to lose integrity, I deliberately edited my favorite Scene (‘Time for Bed’), and can confirm that doing so left that Scene completely empty except for several time delays it had. I must now recreate that Scene from memory.

Will hold off using the beta app any further until these issues are resolved.

@Anna I have a question.
How come this release doesn’t have any known issues? Or did you guys didn’t find any?
The app pretty much crashes at each step and has very obvious bugs.
On my wife’s phone I have 7.40.344 “Temporary downgrade” and that app is better. What happened?

1 Like

Hi @hienry_k9! Thank you for the feedback!

This post is about an update in Beta and it’s purpose is to get feedback from our Beta testers. Generally, we don’t write known issues for the Beta builds.

Please try to reinstall the app and tell us how it goes.

We published a new version yesterday. You can check the update on the Play Store.

Thank you @LibraSun for your valuable feedback!

I passed it to our dev team.

By the way if you have Vera Edge with the new Ezlo Linux FW you can also try to use the Ezlo VOI™.

1 Like

As reported on this forum before, Still not able to see more than 6 devices in device area, even tho i have over 20 devices added.

Also app constantly crashes so unuseable

SOLVED: See Ezlo VOI™ step-by-step guide with videos

Color me confused. On the one hand, I was told ‘Ezlo VOI’ requires either the Ezlo PlugHub or Atom to work.

Yet the promotional emails I keep getting say, rather unambiguously, that this new platform/technology also works with Vera controllers, as well as the “Vera app” (does this mean Vera Mobile??).

The messaging I’m getting is therefore a bit confusing. Can we Vera owners and VeraMobile users employ Ezlo VOI now? If so, how? And if not, why not, or when? (ANSWER: No, only VeraEdge controllers running the alpha Linux OS, using either mobile app.)

1 Like

For a walkthrough of setting up Ezlo VOI™ and incorporating it into your workflow…

Also see:


HOW can users delete GeoLocation waypoints from the app? I had created two Scenes to test GeoFencing (never worked at the time, so I deleted them).

Now, I don’t see a way to remove the two associated lat/lon locations using the app. It’s hard to even ask this question, because they are not “devices” or “scenes” themselves, just some other hidden entity appearing on my controller.