Battery powered devices job control


Got my Vera 3 controlling both battery and non-battery powered devices. This causes a problem for me: When the Vera tries to set value of my Batt Powered Danfoss Living Connect Zs it will try to reach the device in a retry-manner with 5 attempts. During this time, the Vera will queue other commands such as flipping on a light switch leading to up to 30 seconds delays. Needless to say this is not satisfactory.

Is there a way to force Vera to go directly to the job state without trying to reach the battery operated devices before next wake up?


Hi Anders
This is just one of the problems with the Danfoss thermostats.
Take a look here.,16723.0.html
Vera ltd. recomend that you downgrade your system to 2.78 instead of 3.20 (under z-wave options).
I hope they will fix the problems in there new firmware and rewrite the danfoss software.
And a new danfoss-z is on its way.
Some seems to be lucky and have no problems.
I have had nothing but problems with mine in two winther seasons.

I understand there is a lot of fuzz going on about the LCs. However, mine work ok. If only the darn vera could be told not to try to set the value on a battery operated device until it wakes up. It would seem a simple if statement to me.

I considered creating my own logic for this but it does not seem like it is possible to write your own call back method to be invoked by vera on device wakeup? Anyone?


Hi @anderschristensen

My LCs work fine and I do not experience any delays for lights (although they may not be instant all the times, but never 30 seconds

I personally do not think the issue is with the LCs themselves as all battery device have to have resends because they are a sleep most of the time.

How many z-wave nodes do you have on you network .
Do you have other battery powered devices?