AutHomation stops working suddenly

Some odd behavior happened to me today, I got AutHomation installed on both my Android phone and tablet, and both are not refreshing correctly (locally and remotely) , i.e., they are not in sync with what Vera webpage displays. I’m pretty sure the app was working well 2 days ago, and the only thing i changed since then is adding a Combination Switch and the Weather underground plugin. I tried clearing the cache and the database, when doing that, none of the devices appear any longer ???

on the other hand, Home Buddy App works fine…

Garrett, should I send you my lu_sdata ? :slight_smile:

Not sure why it would get out of sync. Click on the reload button in Vera’s Web interface and then do a refresh in the authomation app. Do you have auto refresh enabled in the app?

  • Garrett

don’t have auto refresh, I usually prefer doing the refresh manually. Tried both refreshing Vera and rebooting Vera. still not working :-
I took a look at my lu_sdata, I couldn’t find anything out of the ordinary.

What version of the app are you running? Did you try removing the app and reinstalling? The plugins should not have a affects on the app.

  • Garrett

removed, re-installed, rebooted. still no go. Now focusing on getting it to run locally only. “auto config” finds it correctly. I’m using the HD version The odd thing is that the app shows that it’s loading, then stops, no errors, yet nothing is showing.

Is there a log somewhere to see whether data loaded correctly or a problem was encountered?

Very odd… Has anything else changed to your Vera? I wonder if something in the lu_sdata is causing the app to not complete the download of the data. Have your tried the alpha version in this sub-forum? Should be version 2.1. I hope to have a newer build out for testing. Been very busy the last month. But maybe give the alpha build a test and see if it still does the same thing? You can also send me your lu_sdata if you like to authomation AT garrettpower DOT com.

Another question, is any of the rooms being populated?

  • Garrett

Any update? Did you get things working or are you still having issues? FYI, homebuddy uses different data than what AutHomation uses. HomeBuddy uses user_data2 which can be very very large, AutHomation uses lu_sdata which in comparison can be 20-30 times smaller in size.

  • Garrett

Sorry, got busy with work. The problem is still there. No rooms are populated at all! I uninstalled and tried version, same behavior :frowning:
I just emailed you my lu_sdata . Like you said, I am suspecting that something in the lu_sdata is causing a problem somehow.

any hint? ???

Did not have time the last few days. I just loaded up your data and all seems to have loaded up correctly. I get all of your rooms and devices. So we can rule out the lu_sdata. I have a feeling it may be your connection settings. How are you configuring your connection settings? Are you using the auto configure option or manual entering the settings? Are you trying to connect local or remote?

  • Garrett


I’m totally baffled, I still have this problem and nothing is working, even though I am just focusing on making it work over LAN (same subnet ) , I tried both auto configure and manual connection.

Since you are working on 2.1 beta, is it possible to have a version that is more verbose or produces a log on what’s happening while loading the data? The strange thing is that the App is not really throwing any exceptions, it looks as if it’s loading the data correctly, but then nothing is populated. :-\ whereas when I tried setting wrong connection settings intentionally, it clearly indicates that there’s a connection error ???


Not sure if you are up to this, but would you allow me access to your Vera? It would make diagnosing a lot easier. This is totally up to you though. Let me know if you are willing.

  • Garrett