Are thermostats supported in VC?

It seems that that they already worked in the past, but for some reasons, thermostats are not working anymore using Google Home.
When trying to connect to a thermostat using the home android App, I have a connecting statement followed by a “not responding”. When checking the log, it throws this error:
at com.rtsservices.conciergeserver.vera.Base.Send(
at com.rtsservices.conciergeserver.SmartHome.Query(
at com.rtsservices.conciergeserver.CSWebContainer.LegalCmd(
at com.rtsservices.conciergeserver.CSWebContainer.handle(
at org.simpleframework.http.socket.service.RouterContainer.handle(
at org.simpleframework.http.core.RequestDispatcher.dispatch(
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)

If I restart the local Java App, I still have the same error for thermostat.
Could you please tell us when this will be corrected and even if it’s a known bug?


This might be one of the functionalities lost when Google removed Concierge Agent.

it is still available … mine still works

My understanding is there were two parts, what is still there now, and the stuff using Concierge Agent.
You used to be able to say “Hey Google, talk to Vera Concierge” and then access stuff not supported by google, such as asking the status of a specific device or controlling device types not supported. Google has since increased the number of supported device types, but Vera Concierge hasn’t been updated since.

have u tried - my ac control works absolutely fine and again im gonna say this … it works ac works with native google home so i can say “OK Google set ac cool to 75” and it does it



Interesting, if the AC type works, it feels like a thermostat should work…

In any case, there was more or less full support for anything on your Vera via Concierge Agent, probably by having Google Assistant send speech to text to Vera Concierge that then sent commands to Vera. Now that it’s shut down, all you get is what can be added into Google Home.

It looks like Google is adding support for most things slowly but surely, so in the end it probably won’t matter.

AC is a z wave therm CT30 Radio Thermostat Company of America CT30e.C1.1.99.simple Programmable Communicating Thermostat without Module, White i have both the z wave modukt and the wifi module in it

I have been able to make it work finally by moving the java concierge to another box and now I can see the ambient temperature and the setpoint. The drawback is that the ambient temperature is in Celsius while the setpoint is displayed on Google home application, in Fahrenheit!
I am setup in Celsius everywhere, Vera, Google… but for any reason the setpoint is in Fahrenheit.
What makes things more strange, is that when I ask (by voice) for the current setpoint using Google assistant it gives me both, correct ambient and setpoint in Cesius.
The veraconcierge log is probably the most interesting part, seems to send the temperature in Celsius after conversion from Fahrenheit, even if they are already in Celsius:


-3.8 = 24 Celsius and -5 = 25 Celsius

I tried to switch to Fahrenheit on Vera and this time, temperature are correctly converted by veraconcierge to Celsius.
It’s like veraconcierge is converting everytime to Celsius, even if the temperature are already in Celsius.
Clearly a bug, can it be fixed?
By the way, I have remarked that door locks are still working using version 2.029 even if the developer states that they are disabled by Google.

Finally found the reason why my thermostat is displayed in Fahrenheit, this is because the VC local java application sends this attribute to Google thermostatTemperatureUnit and it’s set to Fahrenheit!
There is no option to specify Celsius.
Google should normally override this value with user preference, but it does not seem to apply to thermostats just weather annoucements.
How come VC is defaulting to Fahrenheit while all the world is using celsius except US!?
Is there any support or further devloppement to VeraConcierge also, seems that the last vesion 2.0.31 has not been updated since more than a year now?

1 Like

The dev has been gone for a while but it’s been said somewhere that he’ll be back soon