Anyone else having problems with Vera Alerts right now?

Mine’s not working. So I tried to Unregister the device and reregister it. When I pressed the unregister button, I get an error that says something like “Error registering with messaging server. SERVICE_NOT_AVAILABLE.”

The phone is on wifi only, and has internet access, verified using a browser. Nothing has changed except that it got unplugged and went dead this morning. I didn’t plug it back in until tonight and it hasn’t worked since I turned it back on.

Did google finally shut down C2DM since it’s no longer supported?

I am still getting messages.

With and without WIFI.

I tracked down the problem. My phone doesn’t have a SIM, so it doesn’t get time from the network provider. When the battery went dead and it rebooted, the time was set to Jan 5, 1980. If your clock is off too much, SSL certs will not validate.

Annoying that the clock reset. Looks like there’s an NTP app on Play called ClockSync that can be used to just pull the time via NTP. I’ll have to install that to prevent this from happening again.