Another "Startup Lua Failed"...

Recently started to receive the dreaded “Startup Lua Failed” error message from my PLEG plugin. I have tried to reinstall the PLEG (I pressed the backup option before the problems started but now I do not know how to restore, I just get a “Command failed:ERROR: Device not ready”) but still get the same error.

I understand you need to view the log to find the cause? I do not really know how to find the log? If I chose “Debug in Standalone File” under Control → Log → Current Debug Status I get this in the pop-up window:

Manual Scroll File not found: /var/log/cmh/PLEG-252.logdata File=FileSpec&Start=N&Grep=GrepSpec Where FileSpec is relative to /tmp/log/cmh or a full spec. N is # of Lines. If N from start else if -N from end. GrepSepc is used to filter the file.

If I choose “Debug in Vera Log file” I get this in the pop-up window:

06 05/19/14 10:42:39.594 Device_Variable::m_szValue_set device: 252 service: urn:micasaverde-com:serviceId:HaDevice1 variable: Configured was: 0 now: 0 #hooks: 0 upnp: 0 v:0xdf00b8/NONE duplicate:1 <0x2ef4f680> 06 05/19/14 10:42:39.594 Device_Variable::m_szValue_set device: 252 service: urn:micasaverde-com:serviceId:HaDevice1 variable: LastUpdate was: 0 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2ef4f680>

I have absolutely NO idea what any of this means. :S Could someone explain like I was a 5 year old how to get PLEG to work again?

For the Startup LUA … you need to put the Log in the Vera Log (Your last option) … then restart Vera.
Then post the log … I (or others) will interpret it … It’s not something a casual user will need or want to know about.

Hmm… I do not seem to get ANYTHING in my log? The pop-up windows (http://MYVERASIPADRESS/cgi-bin/|luup_log:PLEGSDEVICENUMBER#) is empty?

First I thought it might have something to do with the ordinary Vera logging USB stick so I tried to reformat it but it seems this did not make any difference.

However, if I try to restore a backup of the previous settings (and get the “Command failed:ERROR: Device not ready” error message) I get an entry in the pop-up window:

“08 05/19/14 19:59:08.940 JobHandler_LuaUPnP::HandleActionRequest device: 252 service: urn:rts-services-com:serviceId:ProgramLogicC action: Restore <0x2f2f2680>”

so it obviously keeps check on what is happening with the PLEG, just nothing about the “Startup Lua Failed” error?

Sigh. :frowning:

Use the following to get your entire log file …

Issue the above command … then do a vera restart … wait until activity slows down and vera is restarted … Send me the log.

I have sent you my log!

This problem is happening again for me… on 6.8

Richard, this is an issue. I beg you… remove the check. It is buggy and causes failures frequently. Only a power-down fixes it … how many months are we supposed to endure this? At what point do you allow those of us having the problem to get code that does not cause us constant failures?

I will need to see the log files … I need to fix this … If I remove the check it is basically unlicensed.
Make sure the Debug to Vera Log File is set to one that is having the problem. If they are all having the problem … the lowest device ID would be preferred.
I need to see the entire LOG from restart to the problem …

Did the log I sent you include the necessary information?

Never got the log.

Just want to confirm I’m having issues with the registration system on PLEG too.

My home has been working sporadically ever since the registration system was introduced in PLEG and it’s been quite frustrating. MCV issues pale in comparison to the stability of PLEG post registration module. I think Richard has taken a deaf ear to my complaints in the PL License Thread (which is the second longest thread on the PL forum). I’m glad others share my frustration.

However, this is the risk you take when you use unsupported, undocumented products PLEG to “save you time”. The source code is even encrypted, so you can’t see what it’s doing or fix it yourself.

I understand Richard does a lot for a little…I do respect his work and talent…and that is why I switched my whole home to use PLEG in January. However, this change has made thousands or hours of research and programming to a registration failure every other day. I think some focus on making the registration rock solid would go a long way to build trust in the solution…and hopefully long term profits. I wouldn’t mind paying more for a version without registration, at least until there is 6+ months of no registration failures.

Don?t know if the PM was sent properly.

Here is the log attached instead.

This looks like you deleted the PLC plugin.
I had a good warning for this before Registration … I will fix this so it’s not so obscure.

I do not understand what this means? Is it not possible to delete the plugin?

I started getting the error message with my old PLEG. I tried to re-install as a way of (hopefully) solve the problem, but still received the same error message.

THE PLEG plugin also needs the PLC plugin to be installed.

The Program Logic Core plugin is installed and has been since I installed the Program Logic Event Generator plugin.

Try to update it … it can’t find the file L_ProgramLogicCEE.lua

Don?t know how to update, but I uninstalled the PLC and re-installed it. That seems to have worked. I lost my settings of the PLEG though. I assume I can?t restore because it is a new instance after the reinstall.

Thank you RichardTSchaefer for the help.

I must say this entire ordeal has not been very uplifting in the terms of user friendliness… :S Shouldn’t the PLC plugin (not the PLEg plugin) somehow flag it was suddenly missing a file?

I assume the problems started with an automatic update of either the PLC or PLEG. Because my home automation now relies on PLEG instead of Veras built-in scenes it seems risky to let the plugins auto update when it could break a configuration that works properly.

How do you other users reason about this?

I think many users turn off the Auto Update.

Did you try to update it … even if it was at the latest version ?

You should be able to restore your configuration from a Backup.

I’m happy to report a new version 6.9 seems to have fixed this issue.

I woke up to another “Startup Lua Failed” for my Program Logic Event Generator plugin. :S

I assume it has something to do with an update or such?

EDIT: Tried to uninstall and reinstall the plugin. Still get the “Startup Lua Failed” error.