Another plugin update


with my new Vera Plus UI7 the RFXtrx433XL is recognized correctly, but with storing the config on the Vera light and porting it to the Vera plus, some of my devices are gone, which means I have to reconnect them.

regards and thanks



Seems that I got the same problem. Vera lite U15 working with RFXtrx for many years.
Got a somfy sun screen, and bought a RFXtrx XL.
Not visible under serial port config.

Upgrade the firmware to the latest version, and upgraded the luup files.
btw, what are the latest files I should use? there are many sets around the internet.

What to do? get a vera plus, or an older RFXtrx E?

Or is there another solution?

Kind regards,


You can download the latest plugin files from this post: Plugin version 1.80 - #19 by tinman - USB RFXtrx Transceiver - Ezlo Community
Once you have the files uploaded you need to create the device. On the Vera WebUI go to Apps → Develop Apps → Create device. On that screen the only thing you need to enter is the Upnp Device Filename. You should also give it a description. Once the device is created Vera should reload. The go back to Apps → Develop Apps → Serial port configuration. The device you just created should be there. Select it from the Used by device drop down. Be sure to set the baud rate to 38400, 8 data bits, no parity and 1 stop bit.

Hi tinman,

Thank you for your response.
I think I already tried that, but maybe in the wrong order?

But there is nothing visible in serial port config, so nothing to configure.
Should I remove the old Luup files? or just upload 1.8 over the existing files?

Also remove the old device in Vera? and recreate it again after uploading the luup files?

Kind regards,


If you’ve uploaded the 1.80 files then you just need to upload the 1.82 files - there are only 2 files in that 1.82 zip file. You need to have all the other files from the 1.80 zip file as well. You do have the RFXtrxXL433 plugged into the Vera - right? Which Vera hub do you have? I’ve not heard of anyone having problems with this plugin when used with a Vera hub other than the Plus. But I’m not sure if the plugin is being used with those other hubs either so I can’t say for sure. I would hope that as long as the hub has a working USB port the plugin should work.


After upgrading the LUUP files to 1.8.2 unfortunately still not working.
The USB device is not visible in serial configuration. my other two devices (connected via a powered usb hub) are visible. Like I said, my old RFXtrx (not the XL version) is working fine. Connecting the RFXtrx XL directly to my vera, (not using the hub) also does not work.

Ik cannot add another reply, because I am a new user… :slight_smile: Yes, I rebooted.


I’m not sure but removing the USB hub will result in changes to serial port numbers. I hope you rebooted the Vera after making changes to the devices attached to the Vera USB port.

I have some news, and some questions.

I could borrow a RFXtrx E from thumbs up for this service. The E version worked right out of the box.
Simultaneously, Vera contacted me, an suggested an upgrade to U17 which I always tried to avoid. :slight_smile:

But having a good backup, and with the help of Vera support we upgraded. Now also my XL seems to work. However, not quite stable… sometimes the screens do not work, and some communication errors.

I uploaded the 1.8.0 (and 1.8.2) files again, (which is much easier in U17) but in the RFXtrx controler I stil see version 1.0. I am not sure if I got the richt version, I do see a lot of LUUP files, is there a way to clean those up? What is the best way? I don’t want to delete the wrong files.

If I delete the RFXtrx device in Vera, all of my kaku devices are also gone. Thats why I would like to only update the LUUP files.

Any tips?

If you have the E version working you should be able to unplug it and plug in the XL version. If you then restart the Vera and refresh its web page everything should work. When you upload files to the Vera hub it normally reloads LUUP - at least it does in UI7. I’ve never used UI5 so I can’t speak to differences between it and UI7 with regard to the RFXtrx plugin. After uploading - to be sure you could re-boot the Vera and then refresh its page in your browser. If you have WinSCP installed on your PC you can use it to search for files. If you search for L_RFXtrx.* you should find L_RFXtrx.lua.lzo (assuming that UI5 compresses files like UI7 does). Its compressed size should be 66810. Similarly searching for J_RFXtrx.js.* should yiels J_RFXtrx.js.lzo with a size of 25389.


I have U17, but I see the path in some of the files:
F:\drivers\RFXCom\1.8.2\L_RFXtrx.lua it seems they dont upload correct? I used the drag and drop, or the browse funcion. Also in WinSCP I see the path in the filename.

I renamed the two files in WinSCP, and now the correct version is visible.
But now I dont trust the rest of the files, and there are a lot in the 1.8.0 folder to rename. :slight_smile:

If you’re running UI7 then you should be able to go the Apps tab → Develop Apps → Luup files and click upload. Then you can browse to where the RFXtrx plugin files have been unzipped on your PC. Select them all and click Open. Vera compress them and will put them in the proper location.

I know, Thats exactly what I did. But the path is visible in the file name. Looks like a bug, but I can’t find anything about this.

So if you go to Apps tab → Develop Apps → Luup files are the RFXtrx plugin files listed there?

Yes, But some of them have the full path in the filename, which I then rename using WinSCP. That does the trick, but strange of course.

Well, if you can rename and eliminate the full path that appears on some of them then I suppose it might work.

Yes, it does, but not a nice thing to do if you upload 30 files… :slight_smile:

When listed in WinSCP are the files compressed? - ending in .lzo?

Yes they are, I thought of uploading the files via WinSCP, but because of the compression, I thought that would not be a good Idea. I Wil ask Vera about this.

Hello Robbie,

have you found a solution ?
i have the same probleme.
Vera Lite UI7 + RFXCOM XL.

Hello Domotic. I really don’t know how Robbie was getting the plugin files on to the Vera hub and having the filenames include the full path. It’s best to use the Vera hub upload button to get files onto the hub. It will copy them to the correct location and compress them at the same time. If any of the RFXtrx plugin files are on the hub but are not compressed it will interfere with the normal way of updating plugin files. BTW, the latest version of the plugin files (version 1.96) are in another thread in this category.

1 Like