Another plugin update

Yes they are, I thought of uploading the files via WinSCP, but because of the compression, I thought that would not be a good Idea. I Wil ask Vera about this.

Hello Robbie,

have you found a solution ?
i have the same probleme.
Vera Lite UI7 + RFXCOM XL.

Hello Domotic. I really don’t know how Robbie was getting the plugin files on to the Vera hub and having the filenames include the full path. It’s best to use the Vera hub upload button to get files onto the hub. It will copy them to the correct location and compress them at the same time. If any of the RFXtrx plugin files are on the hub but are not compressed it will interfere with the normal way of updating plugin files. BTW, the latest version of the plugin files (version 1.96) are in another thread in this category.

1 Like

Hi tinman

it’s impossible to declare the rfxcom XL on my Vera Lite.
i try since several days.
i have upload the plugin files V1.96, and it’s the same problem. i can’t see the windows where we must configure the serial port (usb/Baud).
help :slightly_smiling_face:

i ask me if the Vera Lite is compatible with a RFXCOM XL.
my hub have 7 or 8 years old. version U17. last version.
For create the device, with RFX XL, is it " D_RFXtrx.Xml" ?

(Sorry, for the mistakes, i’m french)

All the steps to take for connecting the RFXtrx to the Vera hub can be found in this thread: RFXtrx Plugin Notes - USB RFXtrx Transceiver - Ezlo Community
Make sure you enter the device filenames properly - they are case sensitive.

Thnk’s you very much for your help.
but, it’s always the same probleme.
impossible to configure the serial port
must i install the app RFX ?

Even if you do not have the RFXtrx plugin files uploaded to the Vera hub, you should still see a serial port that could be configured if you have the RFXtrx transceiver connected to the Vera hub USB port. If you have the RFXtrx connected to the hub but do not see a serial port then something else is wrong. Once you have the RFXtrx connected you have to do a LUUP reload OR a power cycle so that the Vera looks for connections to the USB port. You can force an LUUP reload by uploading a file - even if you had already reloaded the file before.

Hi Tinman

thank’s you for the response.

I’m giving up.
it’s impossible.

i have bought a VERA PLUS.
i hope, it will be OK.


Perhaps the link below will help. This web page explains how to set up rfx com to work with your vera.

Configuring VERA UI7 to work with RFXtrx433 transceiver

Hi Domotic,
the Problem is the Vera Lite. I had the same issue with my Vera Lite and an XL, so I gave up too and upgraded two years ago to a Vera Plus. That runs mostly fine.


1 Like

Hi Domotic,
Sorry for the late reaction.
On my Vera Lite I just renamed the files using WinSCP and that worked.

Now I also bought a Vera Plus, (I bought a new light switch that did not include in Vera Lite, and thought it would be time for e new model. )

Just uploaded the 1.9.6 files using the upload function in Vera Plus, and that seems to work.

Haven’t had time to test the RFX trx, will have to transfer all the devices.



me too !
i will receive my vera Plus tomorow.
Wait and see :slight_smile:

Hi Domotic,

I have the same problem you had, but then with the VeraPlus and RFXtrx433XL. I loses the connection 2-3 times a day and have to reboot the device. Then go into the serial [port settings and change them. Did you solve the problem?

Is the RFXtrx433XL the only thing connected to the USB port? Or are you using a USB hub to attach additional devices?

Hi Timan,

It’s direct connected to the USB. It loses it’s connection at least once a day and full reboot of the controller is necessary to get in the web interface the serial settings. Is there a way to implement these permanently?

I believe that the serial port connections are detected during a reboot. I don’t think there is a way to set them permanently. Obviously the real problem is the initial loss of the connection. I don’t suppose you are experiencing brief loss of power or brown-outs? I’ve not heard of this kind of problem before.

Hi Tinman,

I think to that the serial is only detected at reboot. That’s the only way to get it working again.
It’s not a problem of power loss or brown-outs, because it’s behind a UPS.
Actually it worked for a couple of months. Out of the blue the problem occurred and I can’t recall any change to the system.
So I guess something is breaking up?

The only thing I can suggest is try to eliminate variables. Since the problem seems to occur often, changing out components may isolate the problem quickly. Try without the UPS, swap USB cables. Over the years I’ve accumulated numerous power supplies. Perhaps you have an extra 12VDC 1.5Amp or better one?
You might want to look at the Vera log file to see if there are any clues there.

hello tinman and thanks for what u doing, can you help me please cause i don’t see any zipfile attached in your post
thank you for your help

It would be best to get the latest version here: Plugin update Version 1.96 - USB RFXtrx Transceiver - Ezlo Community