Am I SOL without winXP/7 for recovery?

Woke up today and noticed that the thermostat hadn’t updated to its morning temperature. Tried to log in to my Veralite and couldn’t connect. Went to the unit and performed a power cycle via unplugging it and waiting a bit. Was then greeted by the endless blue flashing light syndrome.

From my searches of this site it would seem a firmware flash recovery is in order. However as the post title would indicate, it’s 2016 and of the many computers I have access to they are all either win8 or win10. Are you really telling me that the official way to restore my device is a 14 year old OS that Microsoft stopped supporting almost 2 years ago?!? Having to track down someone who still has a win7 machine and install a virtual XP mode seems ridiculous. And if I have to pay for a VM software I might as well buy a new Veralite for the cost.

Am I missing something here guys or is this really my only option?

Thanks.

ninj4, the best thing to do in situations like this is to contact Customer Care. Please email support@getvera.com and CC me and we’ll try to get you sorted.

So that’s a yes on XP or nothing then. Noted. Resonating with this post right now: http://forum.micasaverde.com/index.php/topic,34870.0.html

Well for anyone else in my situation it will take you far more time then it should but if you get winXP running in a VM software on your win 10 computer it takes a couple extra steps to get the recovery software to see the veralite.

Follow the existing steps to prepare the vera so the Z-wave light is blinking and it is connected directly to the host computer.

  1. Set the host computer IP settings to
    IP: 192.168.0.100
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.0.1

  2. Set the VM software network mode to Bridge

  3. Set the Virtual XP IP settings to
    IP: 192.168.0.101
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.0.1

  4. Launch the recovery software and the vera device should actually appear now. Continue with the existing directions to update the firmware.

I should note that a successful flash the vera did not become available at 192.168.81.100 as indicated in the recovery instructions. Instead the network light just kept flashing and when I connected I was greeted by a black screen with red text saying it could not connect to the net and download what it needed. Following those instructions I connected it back to the internet and rebooted the veralite. After waiting a good while the vera was functioning again although it was restored back to UI5 (though it shipped with UI7). Several firmware upgrades later and a restore of my last backup and things were back to normal despite loosing an entire evening to this issue.

For the record MiCasaVerde, when it comes to controlling my house or business, I care about reliable systems that I can feasibly support myself. I do not care about flashy UI or apps. While the community has been amazing, after 4 years and 3 vera systems my experience with the hardware has been a buggy mess.

Maybe the documents that you are reading were written before Windows 10 existed. Maybe it will work on Windows 10. Have you tried?