Alexa wont discover devices

Hi Everyone,

I am currently trying to get my new Echo Plus (Canadian Version) to run my Vera lights and scenes. What I am using is a Windows PC, running HA-Bridge 5.1.0, I also updated to the newest version of Java and the inbound firewall is configured to allow Java through. I also created a batch file with the following line: java -jar -Dserver.port=8080 ha-bridge.jar.

When I start the batch file, then open Google Chrome, I type in my windows pc IP address ( and HA Bridge starts fine. I am also able to go into the Bridge Control tab and configure my vera. When I save (or Bridge Reinitialize) I do get the Vera Devices and Vera Scenes at the top. As well, I am able to pick one of my lights (in Vera Devices), build item and the light now shows in the Bridge Devices tab. I am also able to test by turning the light on and off…works great up to this point. However, when I ask Alexa to discover devices (or try manually via the web browser or my android app), Alexa does not find the device?

I did try other ports that were not used (I tried 8081 and 8085), I also tried an older version HA Bridge jar file (3.5.1)…and still nothing seems to work. I also checked if uPnP was enabled on my router, it is enabled.

Is there something that I am missing here or doing wrong?

Logout of the vera controller on the webpage, then log in again and before you go to your controller check the right top on the page there is a menu, and in there it says manage Alexa, there you give it permission to access devices.
hope it helps

1 Like

You seem to have done everything correctly. If your Alexa & habridge are on the same network, they should see each other.

My Echo Dot as working successfully for months with Vera, discovering devices and responding to commands to turn them off and on.

Now it has stopped responding. As I’ve added new devices to Vera, Alexa does not find them. Nor does it find new scenes. And if fact, it still “remembers” old scenes that I have deleted and which it adds back.

How do I restore to “normal” operation?

Put this here as a reminder…

Thanks for that photo of the opening screen. I had no idea it was even there! It helped…

You are so welcome :slight_smile:


I have find a bug with alexa and google home integration, the reason is the id of device with more of 26 carater.
I have DSC plugin and he make automaticly the name the of eatch device with more of 26 caracter. And when you whant to activate google home or alexa it dont work.

For alexa you can add your account but when you whant tu discover device, he do not find it.

Beacarfull to your device name lenght to integrated home assistant !!!