Alexa TTS (Text-To-Speech) [and more] plug-in for Vera

Curious as to what gives that away?

Cheers

C

luup_log:621: VeraAlexa(executeCommand@225): Response from Alexa.sh: "cookie does not exist. logging in ... ERROR: Amazon Login was unsuccessful. Possibly you get a captcha login screen.  Try logging in to https://alexa.amazon.ca with your browser. In your browser  make sure to have all Amazon related cookies deleted and Javascript disabled!  (For more information have a look at /storage/alexa/.alexa.login)  To avoid issues with captcha, try using Multi-Factor Authentication.  To do so, first set up Two-Step Verification on your Amazon account, then  configure this script (or the environment) with your MFA secret.  Support for Multi-Factor Authentication requires 'oathtool' to be installed." <0x738f0520>

Heres the error im running into, I don’t quite know how to get around it. Any help?

Scratch that I followed @ElCid work around and everything worked just fine!

2 Likes

Couldn’t think of many ways to utilize TTS. Do any of you have any recommendations or ideas i could use!

I have a couple of working instances;

When we go to bed, there’s a Reactor that Alexa triggers that shuts all the lights out, turns the stats down and arms the security, then I get speech confirmation that the security is on.
Similarly our ‘I’m getting out of bed to shower’ has an audio confirmation that the Security is disarmed. Or it gets far too noisy for a pre-coffee morning.

The other one I really like is linked to iPhone locator. I tend to WFH quite a lot and it’s useful to know when Mrs C is nearby, so I have another reactor to tell me when her ETA is sub 15 minutes (the logic is a tiny bit more complex). That makes an audio announcement that says Mrs C will soon be home then tell me the ETA in minutes. That I love. The ETA is a bit out, but that’s a mapping issue, not a Vera problem and it’s close enough :slight_smile:

Having managed to dynamically create TTS I’m struggling to think what you can’t use it for. Anything that wants audio confirmation. Status reports on your house, or your weather sensors? What’s the temperature in the room? The sky’s the limit :slight_smile:

C

PS I was involved in the early days of what became Siri (actually rather more than involved but…) and I have this bee in my bonnet about why we still have 102 bloody switches to communicate with our computers… So TTS is a big thing for me :smiley:

Doors/entryways (I have 4) open, because I can’t ear people coming in and it’s scary, even if they’re family members.

Wind/rain sensors triggered.

Dishwasher/laundry done notifications.

Temperature briefing (linked to a routine).

Scenes confirmation.

And much more.

1 Like

Some interesting uses thanks!

1 Like

@ElCid it is still not working for me, can you please list all the steps you did to have it running on your system?
also you mentioned nod-red skill that is doing the same job, i tried searching for it but could not find it in Alexa skills nor on my Vera apps?

many thanks,

@shady.hamilton how far have you got?

C

here:
Hello @therealdb , I am not sure if i did something wrong but it is not working for me, can you help please,

** I downloaded all the files and uploaded them to my Vera Plus (running Beta .30 firmware)*
** created the device as described and rebooted Vera*
** changed my username and my password Only (I have a US account)*
** created a manual scene and put the following in the luup code:*
luup.call_action(“urn:dlna-org:serviceId:DLNAMediaController1”, “Say”, {Text=“Hello from Vera Alexa”, Volume=50, GroupZones=“Bedroom”}, 214)
I have a group named Bedroom and i have an Echo device named Bedroom, i tried to run the scene many times but didn’t get anything?

what i am doing wrong?

thanks,

OK.
So you have the TTS device and it’s 214?
You have
Username
Password
Language
Alexahost
Amazon host?
Can you share those? Not user and pass obviously?

Finally have you checked for the presence of the /storage/alexa folder and the contents of it?

C

Ok, here are the variables:
You have
Username
Password
Language en-us
Alexahost pitangui.amazon.com
Amazon host? amazon.com
Can you share those? Not user and pass obviously?

I checked using SCP and the folder Alexa has only the sh file but nothing else…

many thanks,

First thing I think the language should be en-US . Could be wrong.

Secondly, does SCP show hidden files? Can you force it?

We need to see if you have .alexa.cookie and so on

C

I was listing hidden files, and only that one was visible, I could be wrong though, i am at the office and can’t have access right now, but i can do it when back home! I updated the language to en-US

Bet you can’t hear it from the office :slight_smile:

OK so no cookie / device / anything else means you’re running into authentication issues.

Have you checked the log for the device?

I go around this by using Firefox and a plugin to grab the cooking from the local Amazon site, then copied it into my folder.

C

Can you tell me the steps please :slight_smile:

From memory(!)

Install Firefox if you’ve not already got
Install the cookies.txt add-on
Delete any cookies you have for Amazon
Go to Amazon
Log in
Export the cookie using the add-on
In your case I guess
rename the cookie.txt file .alexa.cookie
scp it to /storage/alexa

Hope and test…

C

1 Like

rename the exported cookie to alexa.cookie or.alexa.cookie (with the preceding dot?)

do you have 2 step verification on your amazon account?

Node-red is not a skill or on vera., Its a server that runs on many platforms. https://nodered.org/

No I don’t have 2 steps verification.

oh, i thought it is a skill.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules