Alexa TTS (Text-To-Speech) [and more] plug-in for Vera

Is your new device 214? I’m guessing so?

Have you checked /storage on your Vera to see if the alexa folder has been created?


214 is the device i created for Alexa yes, storage is ok, i have a script running every week for cleaning, and i checked that the files were added, but i didn’t check if the folder is created. but how the folder will be created? i just uploaded the files but didn’t create any folder?

The folder should be created when the device is created. There’s a curl to grab it from git hub
If it’s not there, something’s gone wrong. Might get an answer in the logs


how to access the log to see what is going on please?

I do it by ssh into the Vera and looking at /var/log/cmh/LuaUpnp.log

I’m going to guess this might be a little beyond your level of comfort?


Well, i tried that before once or twice :slight_smile: but i prefer if there is simpler way of course…

I’m not aware of one, unless you have AltUI installed?


you maybe got a captcha during login - and that’s very hard to avoid. please take a look at the filex under /storage/alexa. you need scp or ssh in order to inspect them. You need to verify that the login cookie is successfully generated. if you go at the orginal github for .sh script, you will find you’re not alone. MFA will help, but AFAIK Vera’s OS doesn’t support the tool used in this configuration.

The .sh script got notification support. On my short list:

  • notifications
  • run automation
  • commands (weather,traffic,flashbriefing,goodmorning,singasong,tellstory)

I’m busy at the moment, but those are on my radar. I will probably start with a very basic, generic endpoint, so anyone can call anything listed on the page with minimal effort.

One question. Is there a change in the volume after an announcement? Might have been a one off but I’ve not looked at this version of the script to check.



yes, volume is changed before an announcement, using the volume param o or the DefaultVolume variable, then changed back to its previous value.

Hmm, odd.

Can we set the DefaultVolume variable?
I only ask as yesterday the notification worked perfectly, but the volume on that device was very very low afterwards.



Yes, you can. I forgot to add that Alexa’s Volume is based on range 0-100, so if you pass 5 as the volume, it will be very low. Try 50 to have a balanced volume. Default is already 50. Omit it in the LUA call to get the default volume. IE:

luup.call_action("urn:dlna-org:serviceId:DLNAMediaController1", "Say", {Text="Hello from Vera Alexa"}, 666)

This will play the text using DefaultVolume and DefaultEcho variable.

Here’s what I executed:
luup.call_action(“urn:dlna-org:serviceId:DLNAMediaController1”, “Say”, {Text=“Rachel will soon be home”, Volume=40}, 167)

The announcement above was at a perfect volume. It was everything later that was really really quiet…

Am I making sense?


yes, because it will get your current volume, save it, execute the announcement at volume 40 (%), then set it back to the previous value. there’s an action to set volume as well. I used to set it in the past at specific hours (ie: when coming back home, when going to sleep), but I stopped, since volume notifications is more useful.

That’s what I thought, but the ‘current’ volume before the announcement, isn’t (or shouldn’t have been) quiet…

I shall see if it happens again.

Just looked at the version of the script that is downloaded. Not sure if this is the active one as the settings don’t match, but I do notice that:

if no current playing volume can be determined, fall back to normal volume


I’ve edited this to a more realistic volume but…

Thanks, again


I could provide both “DefaultTTSVolume” and “DefaultVolume” and overwrite this parameter as well. I’ll add it to the backlog for the next iterations.

1 Like

No panic :slight_smile:


I have the device created and have setup my lua to run in a scene, but the scene fails.
The logs show LuaInterface::CallFunction_Scene Scene 113 failed attempt to call a nil value <0x71078520>.
Does this mean anything to you guys? I am at a loss.

You have the /storage/alexa directory?

if you ls -a in there you need to have the .sh script and the cookie file. That would be first on my list to check


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules