Alexa TTS (Text-To-Speech) [and more] plug-in for Vera

Hi, before I kick off to start playing… I go to https://github.com/dbochicchio/vera/tree/master/VeraAlexa and I find to install some files in the text, but they do not seem to match with the files in the repo, should I install these in vera:
image
without the readme.md?

Is the text outdated in guthub? Or am I missing things?

Looks about right. I have all of those (not the README)
For peace of mind I’d use this link

And get everything in a Zip file by hitting ‘Clone or Download’

Extract them all and you won’t get any odd formatting issues.

C

Yes, done that. That is th file list of the directory called “VeraAlexa”

But the text says to install:

Thus I just have to ignore the text and upload all fies to vera of that directory called “VeraAlexa”, except the readme file of course?

You need to upload all the files.
Then create the device which uses a subset of those files.

Making sense?

C

Exaclty. Upload all the files, and then create a new device under Vera. I will update the instruction for more clarity. Readme and png are not needed at the moment.

Okay, device is installed… but upon execucting lua code nothing happens (as shady from above).

And then I am lost…

  1. What to do with "does SCP show hidden files? Can you force it?? Where to use SCP? on Vera? How?
  2. What to do with a cookie?

Where can I see logs and how can I get there?

Thanks!

EDIT:
It works!

For all other dummies:

  1. install this in vera: https://github.com/dbochicchio/vera/tree/master/VeraAlexa
  2. Create device in vera (https://github.com/dbochicchio/vera/tree/master/VeraAlexa)
  3. Fill in credentials and use en-US as Language in variables. Also use the name of you alexa as “DefaultEcho” and below at step 11 (Living).
  4. install in firexfox "add-on named coockies.txt
  5. clear all cookies in firefox
  6. log in to alexa.amazon.com
  7. click on the icon of the installed add-on and create a file .alexa.cookie
  8. Use winSCP and log in to vera (see here to find credentials: http://wiki.micasaverde.com/index.php/Logon_Vera_SSH
  9. In vera (via winscp click “…” and go to: image
  10. Pull the cookie file in that directory
  11. (i used altui to test): luup.call_action(“urn:dlna-org:serviceId:DLNAMediaController1”, “Say”, {Text=“Hello from Vera Alexa”, Volume=50, GroupZones=“Living”, Repeat = 3}, 1296) (where the alexa created device ID is 1296.
    I executed the code (in altui) and she spoke!!! 3 times :slight_smile:
    YAY!

However, there is “some” delay like about 10 seconds

2 Likes

Glad we were able to help :wink:

C

yep, the delay is in code. I will push a new version later today, with no delay.

1 Like

New version is online. First message should be spoken immediately know. There’s also support for routines, under openluup only at the moment. This is still beta software, so YMMV.

What files to upload this time :slight_smile:

*.lua and *.xml files should be updated.

:cry: uploaded them but now it doesn’t work anymore…

EDIT: uploaded previous 4 files and it works with 7-10 secs delay again…

Same here, stopped working after new files uploaded

No errors in log. All files in storage/alexa. l

Ok, I will need more time to test under beta. Unfortunately I’m out of town at the moment and I can only test with openluup (where it’s working ok).

1 Like

Take the time, I think it is awesome already!

1 Like

Hi, had any chance to look into?

I’m busy at the moment, but I’ll try to find some time tomorrow.

Struggling to get this working on my Vera Edge latest 1.7.4832 (7.30) firmware.

In the /storage/alexa folder I can only see the alexa_remote_control_plain.sh file present

None of these other files are being generated.

.alexa.cookie
.alexa.devicelist.all
.alexa.devicelist.json
.alexa.devicelist.txt

I entered my Amazon username and password in the variables tab of the device in Vera.

Also if you are in the UK do you need to change the “AmazonHost” to amazon.co.uk rather than amazon.com ?

And the “AlexaHost” from pitangui.amazon.com to alexa.amazon.co.uk ?

I tried this anyway but makes no difference.

I also tried manually creating my .alexa.cookie using the Firefox cookies.txt add-on as previously described and copying the file in to the /storage/alexa folder, but again made no difference, the Echo Dot never speaks the TTS message.

Thanks

How are you seeing what’s in the /storage/alexa folder?

I have
layla.amazon.co.uk
as the Alexa host and
amazon.co.uk as the amazon host

C

Just using Winscp on my Windows laptop could they be hidden files or something ?

EDIT: In Winscp you can press Ctrl+Alt+H to turn viewing hidden files on / off.

I turned it on and there is only the .sh file in the /storage/alexa folder.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules