Aetoec Multisensor -- helpful info

Hi Folks, I’ve been chatting with the good people at Aeotecand they’ve been very helpful in providing info on configuring he 4in1 sensor. In particular some of the weird behavior some of s are seeing ma e due to power management of the sensor. Notably, it parameterizes itself differently on inclusion depending on if it was on USB power or battery when the include is performed…(!)

Aeotec will be posting the below on their website in a bit but with their permission here is a draft for your perusal now:

===From Aeotec===
Congratulations on your purchase of an Aeotec Multisensor. Before you make your new sensor a part of your Z-Wave network, you should ensure that your Multisensor’s firmware is updated to at least V1.18 and above.

To Update Your Multisensor Firmware.
NOTE: Currently, all Aeotec firmware can only be updated via Windows OS.
If your Multisensor is not using version 1.18 of the Multisensor firmware version V1.18:

  1. Download and install USB to UART drivers if you have not done so. The driver is produced by Silicon Labs and you download it here.
    This is needed so that the Multisensor can establish a COM port connection from a USB connection.
  2. Download the latest Multisensor firmware.
  3. Plug the Multisensor via USB into your PC.
  4. Open up the Firmware application, if it is a .ex_ file, change the extension to be .exe
  5. Run the application, and wait for the application to display Update Complete.
    Battery or USB power.
    During normal use the Multisensor may be powered either by batteries or by USB connection. However, because the power source that is being used to power the Multisensor at the moment of its first inclusion into the Z-Wave network has a bearing on the settings that are established during the inclusion process, it should be decided in advance whether USB power or battery power will be the intended power source during normal operation. That intended power source should then be used to power the Multisensor when it is added to your Z-Wave network. In other words if you intend to power the Multisensor by USB over the long-term, then you should power the Multisensor by USB when you include the Multisensor into the network. Likewise, if batteries will be your long-term power source, then use batteries to power the Multisensor at the time of inclusion.
    Battery Powered Multisensor.
    On battery power, the Multisensor can be installed with ease in a multitude of locations. That means that the Multisensor will put some of its features into a dormant mode in order to conserve battery life. While the Multisensor is asleep, the device cannot be actively queried by your network, but it will pro-actively send its own reports to your Z-Wave network depending on your settings. Using battery powered mode with your Multisensor will require you to take the extra steps of configuring the sensor’s parameter settings.
    USB powered Multisensor.
    USB power gives you the greatest control over the Multisensor; the sensor will never go to sleep and you can configure the sensor from your Z-Wave network whenever you want. This advantage contrasts with the ease of installation presented by the Multisensor’s battery-powered functionality.
    Setting up the Multisensor.
    Before including the Multisensor into your Z-Wave network, you should put the Multisensor into the area where it is intended to operate long-term. This will ensure that the nearest neighbours in the Z-Wave mesh network is populated properly at the time of inclusion. You will want to move your primary controller (whether it’s the Z-Stick, a Gateway or so on) within 2 to 3ft of the Multisensor to include it. You can then follow the inclusion instructions in the Multisensor user guide. Once the Multisensor has been added to your network it is recommended that you leave your primary controller and Multisensor to configure themselves for 1 to 2 minutes. After this period, you can move your primary controller back to its original location. Position the Multisensor in the area of operation
    Summary of the above in steps.
  1. Move Primary controller (ie. Z-Stick, Vera, etc.) to the Multisensor
  2. Set the primary controller into inclusion mode
  3. Tap the button on the Multisensor located under the removable panel
  4. Wait for the inclusion process to finish (I suggest waiting 1 minute afterwards just in case)
  5. Move your primary controller back to its original position
    First Time Installation on Vera if Auto Configuration is Enabled (Continuation of setup)
    The Vera can auto configure the Multisensor to have all the necessary parameter settings, but in some case will fail to get the automatic settings sometimes. Below are the steps to ensure that all the settings in the Multisensor are automatically configured.
    8.) Wake up the Multisensor (if it is not awake [red LED not on]) by tapping the black button 3 times in a row, the red LED will turn on to indicate that it is awake and should remain on for 10 minutes.
  6. Poll the Multisensor (Motion Node) [Allow for Auto configuration]
  7. Put the Multisensor back to sleep by tapping the black button 3 more times, the red LED will turn of to indicate that it is asleep.
    Recommended Parameter Settings
    NOTE: If your Multisensor is battery powered, make sure that you wake up the Multisensor before you poll or send any new configurations to this device or you will get an error message from your software. Follow the steps under the Battery Power section below before sending in the configurations.
    USB Powered Multisensor
    Parameter 3: 240 (Timeout period of no-motion after motion sensor trigger)
    Parameter 4: 1 (Enable PIR Motion Sensor)
    Parameter 101: 224 (Sets sensors [Light, Humidity, and Temperature] to be reported in group 1)
    Parameter 111: 240 (Sets the interval of reports for group 1)
    Battery Power Multisensor
    Wake up the Multisensor before sending in configurations
  8. Tap the Multisensor button located inside the back panel 3 times repeatedly (Make sure that the red LED remains on)
  9. Go to your Z-Wave software and enter the configurations below:
    Parameter 3: 240 (Timeout period of no-motion after motion sensor trigger [timeout every 240 seconds after triggering motion])
    Parameter 4: 1 (Enable PIR Motion Sensor)
    Parameter 101: 225 (Sets sensors [Light, Humidity, Temperature, and Battery] to be reported in group 1)
    Parameter 111: 600 (Sets the interval of reports for group 1 [report parameter 101 every 10 minutes or 600 seconds])
  10. Put the Multisensor to sleep to conserve battery power, tap the button on the Multisensor 3 times repeatedly. The red LED should turn off to indicate that it is asleep.
    Miscellaneous Information
    Directly Associate the Multisensor to a Light Switch (Example using a Minimote as a primary controller)
    If you are using a Minimote as a primary controller, you can still use the Multisensor to control lights as a PIR motion sensor, but you cannot see any of the other sensors working. Heres how to control a light:
  11.  Press the Associate button under the Minimote panel (Button on the bottom left)
    
  12.  Press the button on the Z-Wave Switch that you want the Multisensor to turn on or off with
    
  13.  Press the switch on the Multisensor
    
  14.  Stop association mode on the Minimote (Press any button), and test if the setup is working.
    

=================

This is all largely covered in the other threads here, but it’s nice to have it in one location.

The only thing missing is that you want to disable vera polling (set polling to zero), or you’ll get lots of false positives from the motion sensor.

I am still unclear on how to set up a lighting threshold to trigger a direct association in Group I.

I want to switch on a porch light when motion is detected and the light level is below a certain threshold. Instead of using a scene, I have used a group I association to the light switch. Now I do not know how to set up a parameter that will only trigger the light below a certain level.

Sent from my iPad using Tapatalk HD

Does this look correct? Red light is on, clicked “configure node right now”, but I get “Failed at: Setting user Configuration” message.

If you change the settings, you either have to wait for the device to wake up on its own, or press the button inside to wake it up and reconfigure.

If the time between wake ups is long, you may get that error.

I for sure had it awake. I’ve tried several other times since. I’ll keep trying and see what I can come up with.

Based on my recent experience, how (exactly) did you add it to the vera?

I 100% defer to @SirMeili on this sense. i witnessed him become an expert while installing his!

I had to make the 101 and 111 properties “4 byte dec” for them to be set properly.

Yes, that is correct. Reference: http://forum.micasaverde.com/index.php/topic,3831.msg118831.html#msg118831

Reference for the parameter values: http://forum.micasaverde.com/index.php/topic,3831.msg118621.html#msg118621

Thank you, jkensai, for putting much of the needed info in one post. As of now, the docs at Vera and Aeotec sorely need updating because they’re misleading and incomplete. The one piece with graphics that came closest to being thorough was this item.

I kept getting the “Failed at: setting user configuration.” error despite the 4n1 being awake and obviously communicating with Vera (getting name, getting mfr, etc.). Your reminder about the 4 byte dec was the key. Thank you!

Just got my Multi-Sensor and I have a few questions. I upgraded the Firmware to 1.18.

I setup the Multi-Sensor according to this forum and when I open Motion and click on Configure Node or Poll Now it completes just fine. If I do the same on Light, temp or humidity it has the error Node Not Configured.

Am I suppose to go into each one (temp, motion, humidity, light) and change the settings?

I read something about Group 1, what is this ?

The sensor has been outside now for about 30 minutes. Inside is 78 and outside is 90. The temp has changed but it changes by 1 degree every 5 to 10 minutes. Right now it says 82. Why is it so slow? why change from 78 then 79 then 80 then 81 then 82 why does it not jump to 90?

Thanks
Jim

You can only configure or poll the parent device and not the child devices.

  • Garrett

Shouldn’t I be able to poll all of them?

The parent works fine but the other 3 say not configured. The only one I configured was Motion.

Jim