Aeotec Nano Dual switch


I have installed two Aeotec Nano Dual switches in my lighting circuit to try. For some reason they are showing up as 3 switches.

It has the main switch with the power usage under it, then 2 more switches appear for the individual relays 1 with a power usage also, the others don’t.

Is this normal behaviour for these switches? This is my first z-wave experience, so I am not sure.

Cheers, Brent

Pretty much normal. I hide the main one and use the two child devices as they are the ones that actually control the switches.

Cheers, Thankyou.

They always say can’t detect device in the vera UI, is that because they go into power saving mode?
They seem to work when I switch them from the computer.

That I can’t help you with. I have a few devices that seem to drop communication now and then yet still work flawlessly. I simply ignore it so long as everything is still working.

These don’t have a specific Device available to select in Vera yet right? You have to use a Generic Device instead?

[quote=“Richo, post:3, topic:197967”]Cheers, Thankyou.

They always say can’t detect device in the vera UI, is that because they go into power saving mode?
They seem to work when I switch them from the computer.[/quote]

Mine always say “can’t detect device” as well :frowning:

I would log a ticket with our Customer Care team to see if they have any solutions for this. See my signature for details.

I have the issue discussed above, where the first child device consistently reports ‘Can’t detect device’ (and I’ve also noticed in LuaUPnP.log that Vera is trying to Poll the first child and getting lots of errors rather than polling the Parent node).

I have logged a ticket with Customer care and they advised that the device was not supported?!?

What do you suggest? The issue seems to be resulting in really poor Zwave performance intermittently.

PS. I managed to exclude the device and my Zwave performance is back to normal. I’m still really keen to get the Aeotec Nano Dual Switch (SW-132-B) working if anyone has any advice!

I’m having similar ‘can’t detect device’ issues with the aeotec nano dimmer. Not sure if it’s related to your problems or not.

Are you finding that it is negatively effecting your zwave performance for other devices? When I had mine included LuaUPnP.log indicated it was spending all its time trying to poll the child and causing lots of errors.

Hi all. New to the forums.
I also am having a great deal of problems with the ZW132-B Aeotec devices. Have started fresh a few times now, carefully adding the three switches I have - and the network seems to work ok for a short while, then becomes totally unusable. I used Vera to add the devices as “AEOTEC AEOTEC NANO SWITCH (WITH ENERGY METERING)” which is model number ZW116 in the Add Device options. It seems to install ok and joins the network. I was wondering if I need to adjust the device parameters manually to improve the communications?

Just wondering folks. If the response from customer support was that the device is not (yet?) supported, then I should ditch the devices and go with some that are. Also, if this is the case then should I just be purchasing exact devices that are supported definitely. I am using the VeraPlus unit, just purchased and at the moment the situation is pretty embarrassing. I have reset the unit around 8 times to factory default and the whole network as well to try to find out what my issues are. Log files and information on how to interpret them has not been a successful avenue.

I know z-wave is a tried and tested system that will work, just not off to a very good start!

As an update. I have tried excluding and adding these devices a few times now, using Generic and any of the other types on offer. Every time a single NANO is added, the whole Z-wave network becomes slow to respond and in-reliable. Tried installing a repeater even though the VerPlus is metres away from two of the installed switches. Log has an abundance of failed jobs and polling issues.

Installed a Fibaro dimmer and Fibaro Dual switch tonight. Everything is working flawlessly at the moment, and he Fibaro units are much smarter, supplied with better information about parameter mods and are immediate in response to the manual switch inputs. Unlike the NANO’s which even got confused at times through manual operation and at minimum had a 0.5 second delay to operate.

I will be sending my three Aeotec NANO Dual units back tomorrow for a refund… That’s the only solution I could find sorry, as the rest of the network is currently operating properly for once.

I’ve also been having issues since adding a nano dimmer. Aeotec has recently sent me a new firmware to try. If only I could work out how to upload the FW. It appears more of a science project than HA system with firmware uploads

You can’t upgrade FW with Vera, you need to use Homeseer for this.

If this is a standard Aeotec firmware upgrade package, it will have a Windows program which works with the Aeotec Z-Stick to do the firmware upgrade. You will have to exclude the dimmer from your Vera, include it to the Aeotec Z-Stick network, and perform the firmware upgrade. After the upgrade, exclude the dimmer and re-include it in Vera.

This is a huge pain, but it will work.

Has anyone tried hacking the settings so the internal switches don’t get polled?

I tried adding the variable ‘PollSettings = 0’ to the light to stop it getting polled, however that didn’t seem to work.

Maybe we could just turn polling off for the internal switches somehow?

OK, so I at least figured out how to disable polling of the device.

If you go to the two child devices, and under the Advanced tab, choose New Service.

Then put in:

New Service: urn:micasaverde-com:serviceId:HaDevice1
New Variable: PollingEnabled
New Value: 0

Then polling the node gets disabled.

This works in as much as the network isn’t flooded with updates, but the status of the switch doesn’t get updated when it’s switched at the wall.

I’m not sure how to program a listener for the device to update it’s status, but I’m looking at it.

Aeotec Dual Nano Switch.

New to group and having issues with Aeotec Dual Nano switch. Joined the Vera Plus network with no problem. Issue is trying to get original light switches to function properly. Read in another Forum to press network connection button 4 times within 1.5 seconds, then toggle light switch once, wait 10 seconds then toggle same switch back. This worked great for the first switch. Works great from Vera and manually. Thought the theory might work for second switch, no such luck. Any clues brains trust.

When you say second switch, you mean S2 or second device entirely?

For S2 you need to press the button 6x

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules