939 Upgrade - Scene Failure

I knew I was tempting fate, but stupidly I upgraded after a couple of weeks of Vera operating properly with 0.900, and low and behold, scenes failed to turn off lights this evening. Oh well, guess it was my own fault, upgrading and all…

Guess I will downgrade back to 0.900.

are you having problems qith 939 or 900?

I am having problems with 939 and a earlier dongle. Still waiting for the new one.
Seems to run slow. seems to re-boot every 12 -24 hrs.

0.900 was stable for me and I had no issues with new dongle for over 3 weeks. Upgraded to 939 yesterday and that is the version that just failed for me tonight.

Hey Chimp:

I had the same thing occur last night. I unplugged and plugged Vera back in and the scenes all now work fine. Hope your fix is as simple.

I experienced a similar problem after upgrading to 939. In my case, because this upgrade followed a complete failure of my entire system, where I had to reset Vera to factory default and rebuild my network from scratch, I sort of forgot about the scene timer failure after everything else was working again. But now that I see this thread, I was reminded that my “Sunset” scene timer stopped working. Perhaps a bug in 939?

Sunrise and Sunset scenes both worked properly today for me. Must have been some sort of glitch.

Strangely my log from yesterday did not show any failed commands, but none of the 5 lights that are turned on after sunset were shut off, I shut them off manually close to midnight.

Here’s hoping this was just a small anomaly for me ;D

We thoroughly tested this for 939 and can’t find any problems with scenes and timers so it should never miss a scene, and if it does, it’s our top priority to fix it. If we have logs to indicate what happened, we can identify and fix it immediately. So if anybody is having a similar problem I recommend this: Go to Advanced, Logs, and check ‘Verbose Logging’ and ‘Lock Log Levels’. Then the next time it happens, go to Advanced, Tech Support and submit a trouble ticket with ‘for Aaron’ in the comments, and indicate which scene didn’t run at which time. We’ll look into it and reply right away.

IMPORTANT: If you check Verbose Logging, the verbose logging turns itself off automatically after 24 hours unless you check ‘Lock Log Levels’, which locks verbose logging on. Remember to uncheck Lock Log Levels once you’re satisfied it’s working (a few days tops), otherwise Vera will be constantly using a lot of bandwidth to upload the large, verbose logs, and this constant zip’ing up and sending files will make Vera run a lot slower. But, it’s the verbose logs that have all the detail we need to know exactly what went wrong.

Mine started missing scenes too. I have a fixed scene that turns the lights off at 11pm everynight. Seems to run about every other day.

Just opened a ticket. Unfortunately I didn’t have verbose logging on! I have locked it on for now to see what happens tonight

Idiot alert (me, I mean)…after I reset/rebuilt everything this weekend when my scene controller kluged up the whole network, I forgot to go back and set my location (country,state,city, etc.). Duh…no wonder my sunset timer didn’t work. Oops…

This is useless

Most days my Vera seems to miss scenes all together

On days when the scenes work only half the actions in the scene actually happen

All of my devices seem to work perfectly when I turn them on/off through the Device screen.

Every day or so Vera hangs and goes into a mode where it is pingable, and you can sometimes get SSH access if you wait 10-15 mins. In this mode it won’t fire any scenes. It seems that if I reboot Vera, and do NOTHING to it, then it won’t hang for a couple of days. If I open up the GUI, then close it, Vera will hang a few hours later.

If I enable Verbose logging, and lock the levels, then Vera crashes after an hour or two and then you cannot retrieve the logs.

Is MCV still reading the forums? I hope they are working on something big.

madas: I’m at 958 and it seems pretty stable. No recent crashes or hangs. Which version are you on?


Think its worth an upgrade?

what is the most recent “announced” version?

I’m not sure if upgrading would fix your problem since we still don’t get a list of bug fixes and feature changes/additions. And we really don’t know what is causing your problems anyway. Since the upgrade was quick and easy for me, and didn’t seem to cause any regressions, I can recommend it. Who knows what it might fix?

Funny you refer to “announced” version. That’s 939 but until someone posts here we don’t really know what is the latest beta version that’s been posted. I think LibraSun was pinging their server, but I haven’t heard anything lately…

OK, i’ll upgrade to 958 and see what happens. Haven’t got much to loose at this point!

I hope they finally fixed the association problem where you cannot associate two devices.

Um, if you figure out how to create an association, let me know.

You can do it under the “Custom Z-Wave Settings”

It worked on previous versions but seems to be broken in all the newer releases

Seems to same in 958 too :frowning:

@madas, since you’re experiencing these problems you might want to publish (in your Profile footer) the list of devices you have hanging off Vera as other do here. Perhaps also the Dongle version, in case that’s not upgraded or whatever.

Given past discussions on hangs (etc), there may be a pattern based upon the specific ZWave devices present in a given network. Mine are almost all Leviton (or Leviton OEM) and the network is completely stable, always has been.

Hows that?

The funny thing is if I don’t use the GUI vera doesn’t crash for a couple of days. As soon as I use the GUI vera will crash a few hours later


As a [broad, general] rule, the more centrally gathered data on software problem occurrences, the easier it becomes to debug it, as you can often see the patterns more clearly.

So, if there was only one thread on “Vera lockups”, and everyone posted their config in their Profile, as you now do (thanks!), then we might start to see a pattern and help MCV’s team diagnose/isolate it a little.

It doesn’t always work, but it can certainly help.

btw, I’d forgotten you had the Schlage lock :wink:

Unfortunately the other lockup thread (if i remember correctly) is in reference to the dongle lockup, which doesn’t happen for me.

Although I agree, single thread makes things much easier. It’d be better if we could access the bug system directly so that we can all contribute to the same tickets.