1.7.760 upgrade -> Luup restart/reload every night at 00:53 CET

Not a show stopper but experiencing since upgrading my VeraLite to 1.7.760 over the past week-end a Luup restart daily at 00:53 exactly… Prior to the upgrade my Vera was very stable and I made no change to the system otherwise (no new device, plug-in or scene, and no change to anything except the regular AltUI update…)

I do not think this is a memory issue (log is enabled to a USB stick and swapping to a swapfile on the USB stick as well) based on my memory usage stats - actually memory usage barely changes after the restart.
Also, I know that the legacy MiOS “Nightly Heal” that could trigger restarts no longer exists in recent firmware versions and I cannot see anything coming from the z-wave chip in the logs aside from the regular polling activity.

Here are the logs (exactly the same pattern each night…):

03 02/05/16 0:53:08.740 JobHandler_LuaUPnP::Reload: dr_reload Critical 1 m_bCriticalOnly 0 dirty data 1 <0x2d7a2680> .. 01 02/05/16 0:53:09.798 Mongoose XXX-mg_stop1 0xbda418 1 1 <0x2ac51000> 01 02/05/16 0:53:11.799 Mongoose XXX-mg_stop2 0xbda418 2 1e[0m <0x2ac51000> 01 02/05/16 0:53:11.800 Mongoose XXX-mg_stop3 0xbda418 2 1e[0m <0x2ac51000> 01 02/05/16 0:53:11.800 Mongoose XXX-mg_stop4 0xbda418 16094360 1 <0x2ac51000> .. 2016-02-05 00:53:12 - LuaUPnP Terminated with Exit Code: 250 ..
I know from searching on this forum that exit code 250 is a clean exit…

Does anyone experience same ? Any cue as to what might cause this ? Again this is not a big issue but I am just perplexed…

Thanks

I can confirm that i have exact the same luup reload.
Here its at 4.30 every night and since last update 760, also on a vera Lite.

Thanks Egbert ! So I am not the only one. Interested in further feeback from the community…

Would like to understand if this is intended beheavior in that 1.7.760 update or rather an issue with my system.

My luup restarts twice a day at 11:00AM and 03:00PM :frowning: :frowning: on my veraedge. My veraege used to go weeks without any restarts.

While checking the system log (“logread” from the SSH shell)I think I found the cause:

Feb  7 00:53:01 MiOS_******** cron.info crond[3015]: crond: USER root pid 9242 cmd //usr/bin/mios-service-sync_ergy.sh

I will try to investigate further (disabling that cron job) as I have read some horror stories on this forum about the (in)famous ergy energy monitoring, but would be good to know if anyone affected with these luup restarts sees same log entries… Just run from the SSH shell the following command and post the result if any output matches your restart time(s):

logread | grep ergy

Thanks

@LV999,

You are right i got this a the luup restsrt time (4.29 at night) :

Feb 7 04:29:01 MiOS_******** cron.info crond[1812]: crond: USER root pid 5680 cmd //usr/bin/mios-service-sync_ergy.sh

So it has something todo with Ergy.
(I never used Ergy, and on the energy tab i also did not accept the terms and conditions)

OK… This is indeed it…

the culprit is a script called on a timer as set in /etc/crontabs/root:

*/1 * * * * /usr/bin/Rotate_Logs.sh #Rotate_Logs 53 00 * * * //usr/bin/mios-service-sync_ergy.sh #Sync_Ergy
obviously I decided to comment out that line as follows:

*/1 * * * * /usr/bin/Rotate_Logs.sh #Rotate_Logs #53 00 * * * //usr/bin/mios-service-sync_ergy.sh #Sync_Ergy
and did a restart of the cron deamon to ensure the edits are in force:

/etc/init.d/cron restart

This should fix the restart… Obviously I am not using the ergy plug-in, so if you are you might want to stay away from making any changes and leave the system “as is”.

Now, I looked at the /usr/bin/mios-service-sync_ergy.sh script and indeed it does call for a luup restart in certain circumstance… Interestingly the file version is signed as follows:

# SVN : $Id: mios-service-sync_ergy.sh 15864 2015-12-15 14:17:23Z florin $
so I will send a pm to mcv.florin to understand why this edit was made on Dec 15th, 2015 and distributed into the 1.7.760 firmware release. I’ll advise if any news.

I have a VeraLite also and it’s rebooting more than twice a day since the upgrade. I used to have to schedule it for weekly reboots. I numerous other issues with this update, but this is indeed one of them.

@jlind, if you are not using Ergy monitoring and savy enough with Linux, you might want to follow what I did… It works for me (but without any warranty from me).

Also Vera Dev Team confirmed to me that it was the unintended of a fix made in the latest f/w to some Ergy issues and that it should be fixed in the next firmware update

Thanks LV999, but I think I’ll hold off doing it for now. I have a new Plus coming next month and plan on moving everything over and using my VeraLite for a test box. I’ll keep that in mind if it gets worse.

[quote=“LV999, post:9, topic:190925”]@jlind, if you are not using Ergy monitoring and savy enough with Linux, you might want to follow what I did… It works for me (but without any warranty from me).

Also Vera Dev Team confirmed to me that it was the unintended of a fix made in the latest f/w to some Ergy issues and that it should be fixed in the next firmware update[/quote]

Thanks LV999. I installed the energy report but uninstalled it but the job is still there. Thanks for sharing this :slight_smile: :slight_smile:

[quote=“LV999, post:9, topic:190925”]@jlind, if you are not using Ergy monitoring and savy enough with Linux, you might want to follow what I did… It works for me (but without any warranty from me).

Also Vera Dev Team confirmed to me that it was the unintended of a fix made in the latest f/w to some Ergy issues and that it should be fixed in the next firmware update[/quote]

LV999, Thanks for sharing, so i wait for next firmware.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules